Problem Description

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42
#include <bits/stdc++.h>

using namespace std;

int main()
{
double x, sum = 0;
int n = 12;
while(n --)
{
cin >> x;
sum += x;
}
cout << '$' << sum / 12.0 << endl;
return 0;
}

最新文章

  1. Using Internal EEPROM of PIC Microcontroller
  2. 微信小程序之小豆瓣图书
  3. SpringMVC实现Restful风格的WebService
  4. Java设计模式-迭代子模式(Iterator)
  5. 华为p7怎么打开usb调试模式
  6. HTML+CSS学习笔记(9)- CSS的继承、层叠和特殊性
  7. 【面试虐菜】—— Oracle中CHAR、VARCHAR的区别
  8. Lintcode--003(乱序字符串)
  9. List 随机排序
  10. DFGUI-- 标签交换 Tabstrip
  11. Jekyll报&#39;Tag was never closed&#39;错误
  12. 关于tarjan算法的空间优化
  13. testNG常用方法
  14. Hadoop学习笔记1:伪分布式环境搭建
  15. anaconda安装opencv(python)
  16. Java+Selenium环境搭建
  17. docker知识点杂记
  18. Oracle HRMS APIs
  19. PHP各环境下的伪静态配置
  20. 改变VO中的sql

热门文章

  1. Python爬虫—requests库get和post方法使用
  2. python 之 Urllib库的基本使用
  3. spark调优篇-Spark ON Yarn 内存管理(汇总)
  4. uva 10325基础容斥
  5. C#之Action和Func
  6. Flask框架入门
  7. c++容易混淆知识点
  8. ES6 map与filter
  9. kubernetes之download api
  10. 02_Hive安装简介