Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2026    Accepted Submission(s):
1428

Problem Description
Tang and Jiang are good friends. To decide whose treat
it is for dinner, they are playing a game. Specifically, Tang and Jiang will
alternatively write numbers (integers) on a white board. Tang writes first, then
Jiang, then again Tang, etc... Moreover, assuming that the number written in the
previous round is X, the next person who plays should write a number Y such that
1 <= Y - X <= k. The person who writes a number no smaller than N first
will lose the game. Note that in the first round, Tang can write a number only
within range [1, k] (both inclusive). You can assume that Tang and Jiang will
always be playing optimally, as they are both very smart students.
 
Input
There are multiple test cases. For each test case,
there will be one line of input having two integers N (0 < N <= 10^8) and
k (0 < k <= 100). Input terminates when both N and k are zero.
 
Output
For each case, print the winner's name in a single
line.
 
Sample Input
1 1
30 3
10 2
0 0
 
Sample Output
Jiang
Tang
Jiang
 
Source
 
Recommend
liuyiding   |   We have carefully selected several
similar problems for you:  6263 6262 6261 6260 6259 
 
 
我们可以把模型抽象一下
有$n-1$个石子,一个人最多拿$k$个,问最后谁赢
——》裸的巴什博奕
 
 
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=1e6+,INF=1e9+;
int main()
{
#ifdef WIN32
freopen("a.in","r",stdin);
#else
#endif
int x,y;
while(scanf("%d%d",&x,&y))
{
if(x==&&y==) break;
if( (x-)%(y+)== ) printf("Jiang\n");
else printf("Tang\n");
}
return ;
}

最新文章

  1. MySQL ROOT密码更改
  2. Python-基础练习题2
  3. WPF实现无边框窗体拖拽右下角▲ 改变窗体大小【framwork4.0】 谢谢大家关注
  4. poj 2342 Anniversary party 简单树形dp
  5. 存储过程&amp;Function
  6. Java实现Http服务器(三)
  7. C# 将MSMQ消息转换成Json格式 【优化】
  8. LaunchScreen.xib 设置启动图
  9. Row versus Set Processing, Surprise!(集合处理和单行处理数据的差异性)
  10. web页面接入QQ客服的方法
  11. Codeforces 842B Gleb And Pizza【几何,水】
  12. Unity Graphics(一):选择一个光照系统
  13. mysql修改用户密码命令
  14. 树莓派3B安装LEDE
  15. ChIP-seq 学习内容
  16. 火币网API文档——WebSocket API错误码
  17. java调用存储过程mysql
  18. 批处理(bat)的注释方法
  19. Codeforces Round #280 (Div. 2) A. Vanya and Cubes 水题
  20. Golang配置文件解析-oozgconf

热门文章

  1. C 单向链表就地逆转
  2. #Java学习之路——基础阶段(第二篇)
  3. 第51节:Java当中的集合框架Map
  4. Python的简单介绍
  5. 哈尔特征Haar
  6. 人生苦短,我用Python(1)
  7. OS之进程管理---多线程模型和线程库(POSIX PTread)
  8. Python Selenium 常用方法总结(不断补充)
  9. C#版 - LeetCode 148. Sort List 解题报告(归并排序小结)
  10. Redis 事物