TOYS

Time Limit: 2000MS Memory Limit: 65536K

Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.



For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0

3 1

4 3

6 8

10 10

15 30

1 5

2 1

2 8

5 5

40 10

7 9

4 10 0 10 100 0

20 20

40 40

60 60

80 80

5 10

15 10

25 10

35 10

45 10

55 10

65 10

75 10

85 10

95 10

0

Sample Output

0: 2

1: 1

2: 1

3: 1

4: 0

5: 1

0: 2

1: 2

2: 2

3: 2

4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.

Source

Rocky Mountain 2003

这是一道基础的计算几何,就是让你计算用线段分出的不规则图形的区域中分别有几个点。这题我们直接二分答案,如果点在当前第mid" role="presentation" style="position: relative;">midmid条线段的左边,那么我们移动右指针,否则我们移动左指针。怎么判断方向呢?直接使用向量的叉积来判断就可以了。

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 5005
using namespace std;
struct pot{
    int x,y;
};
struct line{pot a,b;}l[N];
int n,m,cnt[N];
int x1,x2,y1,y2;
inline int cross(pot a,pot b){return a.x*b.y-a.y*b.x;}
inline bool dir(int k,pot p){
    pot a,b;
    a.x=l[k].a.x-p.x,a.y=l[k].a.y-p.y;
    b.x=l[k].b.x-p.x,b.y=l[k].b.y-p.y;
    return cross(a,b)>0;
}
inline int search(pot p){
    int l=1,r=n,ret;
    while(l<=r){
        int mid=(l+r>>1);
        if(dir(mid,p))l=mid+1;
        else r=mid-1;
    }
    return r;
}
int main(){
    while(scanf("%d",&n)){
        if(n==0)break;
        memset(cnt,0,sizeof(cnt));
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        for(int i=1;i<=n;++i){
            l[i].a.y=y1,l[i].b.y=y2;
            scanf("%d%d",&l[i].a.x,&l[i].b.x);
        }
        for(int i=1;i<=m;++i){
            pot p;
            scanf("%d%d",&p.x,&p.y);
            ++cnt[search(p)];
        }
        for(int i=0;i<=n;++i)printf("%d: %d\n",i,cnt[i]);
        puts("");
    }
    return 0;
}

最新文章

  1. Hibernate+EhCache配置二级缓存
  2. svg.js教程及使用手册详解(二)
  3. 【Solr】 solr对拼音搜索和拼音首字母搜索的支持
  4. Sqlserver_视图
  5. 【转】iOS静态库 【.a 和framework】【超详细】
  6. 第二百二十九天 how can I 坚持
  7. 实例源码--Android旋转式菜单(效果很炫)
  8. python app progs
  9. C# 委托和方法
  10. 浅谈“Mysql”的基础操作语句
  11. Solve Error: node postinstall sh: node: command not found
  12. [转帖]一键获取 所有连接过的wifi 密码
  13. problem:浏览器如何区分html超文本和普通文本
  14. 安卓打开远程调试(免root)
  15. c# Bitmap byte[] Stream 文件相互转换
  16. RHEL7 MariaDB测试
  17. 两台linux服务器之间实现挂载
  18. hbase读写流程分析
  19. Java直接用javac来编译带package的类
  20. react路由传参

热门文章

  1. myBatis连接MySQL报异常:No operations allowed after connection closed.Connection was implicitly closed
  2. js实现UTC时间转为北京时间,时间戳转为时间
  3. H5新标签
  4. pyspark dataframe 格式数据输入 做逻辑回归
  5. HttpClientUtil 工具类
  6. git仓库搬家
  7. Python3 len()方法
  8. eclipse搭建struts2环境及所遇到的问题
  9. Clustered Index &amp; Non Clustered Index(聚簇索引和非聚簇索引)
  10. 【英宝通Unity4.0公开课学习 】(五)47讲到75讲