problem

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

\ Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 10^5^), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1: 67890
Sample Input 2: 00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2: -1

tip

  • 模拟指针

answer

#include<iostream>
#include<stack> #define Max 100010
using namespace std; struct Node{
int t;
char d;
bool flag;
}node[Max];
int N, f1, f2; int main(){
// freopen("test.txt", "r", stdin);
for(int i = 0; i < Max; i++) node[i].t = -1;
scanf("%d%d%d", &f1, &f2, &N);
int f, t; char d;
for(int i = 0; i < N; i++){
scanf("%d %c %d", &f, &d, &t);
node[f] = {t, d, false};
}
for(int i = f1; i != -1; i = node[i].t) node[i].flag = true;
for(int i = f2; i != -1; i = node[i].t){
if(node[i].flag ) {
printf("%05d", i);
return 0;
}
}
printf("-1");
return 0;
}

experience

最新文章

  1. WinForm richtextbox 关键字变红色
  2. Nginx搭建flv视频点播服务器
  3. Hadoop2.2.0 自动切换HA环境搭建
  4. Nginx - HTTP Configuration, Module Directives
  5. mstsc 终端服务器超出了最大允许连接的解决办法
  6. JavaScript的垃圾回收
  7. 3.Android Studio系列教程3——快捷键
  8. js动画学习(三)
  9. HDU 4916 树分治
  10. 介绍一款轻量级js控件:easy.js
  11. 马哥k8s
  12. 《剑指offer》第一个只出现一次的字符
  13. 探究osg中的程序设计模式【目录】
  14. WHU1124 Football Match
  15. struts2 中 paramsPrepareParamsStack 拦截器
  16. python subprocess 和 multiprocess选择以及我遇到的坑
  17. Spring MVC的handlermapping之请求分发如何找到正确的Handler(BeanNameUrlHandlerMapping,SimpleUrlHandlerMapping)
  18. PHP学习4——面向对象
  19. Freemarker中JS取Data-model的值的问题
  20. curl myip.ipip.net curl ip.cn curl cip.cc

热门文章

  1. 【leetcode 简单】 第七十九题 区域和检索 - 数组不可变
  2. 天梯赛 L2-023. (模拟) 图着色问题
  3. 倍增 Tarjan 求LCA
  4. 动态SQL中变量赋值
  5. Servlet笔记1--概述
  6. 怎么修改oracle用户密码
  7. Gh0st配置加密与解密算法(异或、Base64)
  8. 【HASPDOG】Communication error
  9. aarch64_n3
  10. bash脚本里su命令执行