For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
struct Fraction{
ll up,down;
}a,b; ll gcd(ll a,ll b){
return b == ? a : gcd(b,a%b);
} Fraction reduction(Fraction result){
if(result.down < ){
result.down = -result.down;
result.up = -result.up;
}
if(result.up == ){
result.down = ;
}else{
int d = gcd(abs(result.up),abs(result.down));
result.down /= d;
result.up /= d;
}
return result;
} Fraction add(Fraction f1,Fraction f2){
Fraction result;
result.up = f1.up*f2.down + f1.down*f2.up;
result.down = f1.down*f2.down;
return reduction(result);
} Fraction muli(Fraction f1,Fraction f2){
Fraction result;
result.up = f1.up*f2.down - f1.down*f2.up;
result.down = f1.down*f2.down;
return reduction(result);
} Fraction multi(Fraction f1,Fraction f2){
Fraction result;
result.up = f1.up*f2.up;
result.down = f1.down*f2.down;
return reduction(result);
} Fraction divide(Fraction f1,Fraction f2){
Fraction result;
result.up = f1.up * f2.down;
result.down = f1.down * f2.up;
return reduction(result);
} void showResult(Fraction r){
r = reduction(r);
if(r.up < ) printf("(");
if(r.down == ) printf("%lld",r.up);
else if(abs(r.up) > r.down){
printf("%lld %lld/%lld",r.up/r.down,abs(r.up)%r.down,r.down);
}else{
printf("%lld/%lld",r.up,r.down);
}
if(r.up < ) printf(")");
} int main(){
scanf("%lld/%lld %lld/%lld",&a.up,&a.down,&b.up,&b.down); showResult(a);
printf(" + ");
showResult(b);
printf(" = ");
showResult(add(a,b));
printf("\n"); showResult(a);
printf(" - ");
showResult(b);
printf(" = ");
showResult(muli(a,b));
printf("\n"); showResult(a);
printf(" * ");
showResult(b);
printf(" = ");
showResult(multi(a,b));
printf("\n"); showResult(a);
printf(" / ");
showResult(b);
printf(" = ");
if(b.up == ) printf("Inf");
else showResult(divide(a,b)); return ;
}

最新文章

  1. 使用GridVIew显示Gantt(甘特图),动态增减列
  2. 利用win7系统自带的dos命令把笔记本无线网卡当无线路由器(无线AP发射器)
  3. Android的构造器
  4. OpenJudge计算概论-完美立方【暂时就想到了枚举法了】
  5. 7)Java数据类型
  6. shadow服务端、客户端配置流程
  7. Android的AsyncTask类的解读
  8. Debian 8 安装BtSync
  9. [Linux] - Linux下安装jdk,tar方式
  10. 【前端】Vue2全家桶案例《看漫画》之七、webpack插件开发——自动替换服务器API-URL
  11. 史上最走心webpack4.0中级教程——配置之外你应该知道的事
  12. nginx 开启gzip 压缩资源
  13. vue后台项目记录
  14. 原生NodeJs制作一个简易聊天室
  15. 【POI每日题解 #8】DYN-Dynamite
  16. Capability Model
  17. Pymongo NotMasterError while fetching count of the collection as per query from MongoDB in DRF
  18. Activity Monitor 闪退 & 无法进入睡眠
  19. html5和css3打造一款创意404页面
  20. 【BZOJ3631】松鼠的新家 树链剖分

热门文章

  1. bzoj 4031: 小Z的房间 矩阵树定理
  2. backbonejs学习
  3. 查看,检查,修复pg的命令
  4. centos7 查看启动ntp服务命令
  5. 用paramiko写堡垒机
  6. C语言学习笔记--单引号和双引号
  7. #410div2D. Mike and distribution
  8. 关于overflow:hidden (转)
  9. hadoop2.6.0完全分布式部署
  10. p1098 逆序对