Phone List
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26328   Accepted: 7938

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES
题意:就是问这些号码中是否存在一串号码是另一串号码的前缀,典型的trie树模板题;
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=100010;
char str[N][10];
int t,n,cnt,trie[N][20],flag,val[N];
void build_checktrie(char*s,int v)
{
int len=strlen(s),u=0;
for(int i=0;i<len;i++)
{
int num=s[i]-'0';
if(!trie[u][num])
{
for(int j=0;j<=10;j++)
{
trie[cnt][j]=0;
}
val[cnt]=0;
trie[u][num]=cnt++;
}
else
{
if(i==len-1)
{
flag=0;
}
if(val[trie[u][num]])
{
flag=0;
}
}
u=trie[u][num];
}
val[u]=v;
}
int main()
{
scanf("%d",&t);
while(t--)
{
memset(trie,0,sizeof(trie));
memset(val,0,sizeof(val));
cnt=1;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%s",str[i]);
}
flag=1;
for(int i=1;i<=n;i++)
{
build_checktrie(str[i],1);
if(!flag)break;
}
if(flag)printf("YES\n");
else printf("NO\n"); }
return 0;
}

最新文章

  1. lua命令行编译
  2. 虚拟机下CentOS 配置IP地址的三种方法
  3. TODO:Node.js pm2使用方法
  4. 【poj1085】 Triangle War
  5. 4个mysql客户端工具的比较
  6. .NET调用window串口读取电子秤的数据
  7. Java基础算法集50题
  8. 使用c#数据库连接池
  9. HashSet与HashMap、Hashtable
  10. OC之字符串 NSString与NSMutableString
  11. struts2 0day漏洞
  12. [LeetCode]题解(python):130-Surrounded Regions
  13. ASP.net体系
  14. CodeForces 546 D. Soldier and Number Game(素数有关)
  15. CTF入门指南(0基础)
  16. 连连看(dfs)
  17. 服务端监控工具:Nmon使用方法
  18. HTML5游戏 看你有多“色” 开发
  19. keras 文本分类 LSTM
  20. c++下基于windows socket的多线程服务器(基于TCP协议)

热门文章

  1. PerconaXtraBackup-2.2.8手册翻译
  2. shader随记
  3. xcode ERROR ITMS
  4. 在UIWebView中设置cookie
  5. K-Piggy-Bank
  6. [转载] 把Nutch爬虫部署到Hadoop集群上
  7. Linux里的发消息
  8. php 验证邮箱的方法
  9. Ubuntu 14.04 或者16.04开启root账户登录和图形界面登录root时候的报错解决方法
  10. LeetCode:零钱兑换【322】【DP】