The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).

Sample Input

3

5 10 2

1 2 3 4 5

5 4 3 2 1

5 10 12

1 2 3 4 5

5 4 3 2 1

5 10 16

1 2 3 4 5

5 4 3 2 1

Sample Output

12

2

0

【题意】: 给定背包容量,骨头的个数和每个骨头的价值,这次不是求在背包容量允许的情况下,最多装的价值,而是求在背包容量内,可以装的第k大价值,如果没有第k个最大值,那么输出0。

【分析】:

求背包的第k大方案,只需在状态上加入一维dp[j][k]表示前i个物品装入容量为j的背包的第k大的方案,用两个数组辅助保存下装和不装两种选择下的前k大方案,再最后合并起来得到最终结果 。

要求的是第K个最大值,那么不用 dp[j]=max(dp[j],dp[j-w[i]]+v[i])的状态转移方程,而是将两个值都记录下来,用for循环走一遍,记录下,容量为1到M的各个最大价值,dp[i][j]表示当背包容量为i时的第j个最大价值,最后只需要输出dp[m][k]即可

【精彩讲解】:HDU2639 01背包 第K优决策

#include<cstdio>
#include<string>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<cstring>
#include<set>
#include<queue>
#include<algorithm>
#include<vector>
#include<map>
#include<cctype>
#include<stack>
#include<sstream>
#include<list>
#include<assert.h>
#include<bitset>
#include<numeric>
#define debug() puts("++++")
#define gcd(a,b) __gcd(a,b)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define fi first
#define se second
#define pb push_back
#define sqr(x) ((x)*(x))
#define ms(a,b) memset(a,b,sizeof(a))
#define sz size()
#define be begin()
#define pu push_up
#define pd push_down
#define cl clear()
#define lowbit(x) -x&x
#define all 1,n,1
#define rep(i,n,x) for(int i=(x); i<(n); i++)
#define in freopen("in.in","r",stdin)
#define out freopen("out.out","w",stdout)
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const LL LNF = 1e18;
const int maxn = 1e5 + 5;
const int maxm = 1e6 + 10;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int dx[] = {-1,1,0,0,1,1,-1,-1};
const int dy[] = {0,0,1,-1,1,-1,1,-1};
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
/*
总的复杂度是O(VNK)
3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1
*/
int n,m,K;
#define S 100000
#define M 200000
int w[1005],v[1005];
int a[1005],b[1005];
int dp[1005][1005];//设dp[j][k]为容量为j的背包所获得的第k大价值
int main()
{
int t;
cin>>t;
while(t--)
{
memset(dp,0,sizeof(dp));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b)); cin>>n>>m>>K;
for(int i=1;i<=n;i++) cin>>v[i];
for(int i=1;i<=n;i++) cin>>w[i];
for(int i=1;i<=n;i++){
for(int j=m;j>=w[i];j--){
for(int k=1;k<=K;k++){ //用两个数组辅助保存下装和不装两种选择下的前k大方案
a[k] = dp[j][k];
b[k] = dp[j-w[i]][k] + v[i];
}
//a[K+1]=b[K+1]=-1;
int x=1,y=1,z=1;
while(z<=K && (x<=K||y<=K)){ //二路归并
if(a[x]>=b[y]) //不能去掉等于
dp[j][z]=a[x++];
else
dp[j][z]=b[y++];
if(dp[j][z-1] != dp[j][z]) z++; //去重
}
}
}
cout<<dp[m][K]<<endl;
}
return 0;
}

最新文章

  1. linux下更新python
  2. java画图之初体验
  3. 红包demo
  4. CodeIgniter框架入门教程——第三课 URL及ajax
  5. HDOJ 4717 The Moving Points
  6. How to raise exceptions in Delphi
  7. loadrunner生成随机数
  8. [Solution] ASP.NET Identity(1) 快速入门
  9. 通用窗口类 Inventory Pro 2.1.2 Demo1(下)
  10. UISegment
  11. C#多线程交替赋值取值
  12. 如何使用深度学习破解验证码 keras 连续验证码
  13. SharePoint 2013 中将 HTML文件转换为母版页
  14. HDU 5904 LCIS
  15. 《JavaScript DOM 编程艺术 》 笔记
  16. 2. 网友对app后端写作系列文章的写作建议
  17. Python--day07(数据类型转换、字符编码)
  18. python numpy 间的的数据变算公式
  19. spring的历史和哲学
  20. 工作随笔—Elasticsearch大量数据提交优化

热门文章

  1. C#中窗体、MDI的使用心得
  2. 《Cracking the Coding Interview》——第3章:栈和队列——题目7
  3. BFC相关知识
  4. (原)Unreal渲染模块 源码和实例分析说明
  5. centos 7 安装codeblocks
  6. python作业:模拟登陆(第一周)
  7. Redis String
  8. zoj 1508 Intervals (差分约束)
  9. 有趣的数(number)
  10. 【CF Edu 28 B. Math Show】