Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 3523   Accepted: 1740
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the
program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 

Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s
subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of
each category. 

Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be
interested in Ivan's opinion about the reliability of the obsolete version. 

A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems.
The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 

Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

题意:一个软件有S个系统。但会产生N种bug。一个人一天能够发现一个bug,这个bug既属于某一个系统。又属于某一个分类。每一个bug属于某个系统的概率是1/S,属于某种分类的概率是1/N。如今问你发现N种bug且S个系统都发现bug的天数的期望。

思路:用dp[i][j]表示发现i种bug且j个系统都发现bug的天数的期望。能够得到4种状态

1。dp[i][j]—— 新bug  既属于已发现bug的种类。又属于已经发现bug的系统。则有概率 (i / S) * (j / N)

2。dp[i+1][j]—— 新bug  不属于已发现bug的种类,属于已经发现bug的系统。则有概率 (1 - i / N) * (j / S)

3。dp[i][j+1]—— 新bug  属于已发现bug的种类,不属于已经发现bug的系统。则有概率 (i / N) * (1 - j / S)

4,dp[i+1][j+1]—— 新bug 既不属于已经发现bug的种类,也不属于已经发现bug的系统。

则有概率 (1 - i / N) * (1 - j / S)

求期望倒着递推,由dp[N][S] = 0 退出 dp[0][0]就可以。注意推导时 全是浮点型。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[1010][1010];
int main()
{
int N, S;
while(scanf("%d%d", &N, &S) != EOF)
{
memset(dp, 0, sizeof(dp));
for(int i = N; i >= 0; i--)
{
for(int j = S; j >= 0; j--)
{
if(i == N && j == S) continue;
double x = i, y = j;
double p1 = dp[i+1][j] * (y / S) * (1 - x / N);
double p2 = dp[i][j+1] * (x / N) * (1 - y / S);
double p3 = dp[i+1][j+1] * (1 - y / S) * (1 - x / N);
double p0 = 1 - (x / N) * (y / S);
dp[i][j] = (p1 + p2 + p3 + 1) / p0;
}
}
printf("%.4lf\n", dp[0][0]);
}
return 0;
}

最新文章

  1. 解决cookie跨域访问
  2. linux 7z 命令编译安装
  3. CF 407B Long Path[观察性质 DP]
  4. 50道JavaScript经典题和解法(JS新手进...持续更新...)
  5. 545E. Paths and Trees
  6. js标题文字向上滚动
  7. 做一个自动修改本机IP和mac的bat文件
  8. 【cocos2d-js公文】十八、Cocos2d-JS v3.0物业风格API
  9. [SDOI2010]古代猪文
  10. 【翻译】在Ext JS应用程序中构建可维护的控制器
  11. 环信easeui集成:坑总结2018
  12. Docker 容器状态查看 - 五
  13. 1_2_3_4_5 Html-Css
  14. 离线应用与客户端存储(cookie storage indexedDB)
  15. mvc core2.1 Identity.EntityFramework Core 配置 (一)
  16. .Net Core vs .Net Framework 如何为一个应用程序选择一个运行时(翻译)
  17. 解密OpenTSDB的表存储优化【转】
  18. Linux 定时任务crontab_014
  19. ibatis中的cdata和xml中cdata的含义
  20. 使用swipemenulistview实现列表的左右滑动

热门文章

  1. Ubuntu FireFox的“后退”按钮与Backspace键
  2. json-gson 解析泛型及解析null
  3. sublime text3中成功使用bootstrap3
  4. 在Alfred添加自定义站内搜索
  5. H5页面唤起手机号
  6. Codeforces Gym101522 A. Ambiguous Dates (La Salle-Pui Ching Programming Challenge 培正喇沙編程挑戰賽 2017)
  7. facebook architecture 2 【转】
  8. usaco-Money Systems
  9. 解决百度ueditor配置上传目录为外部目录时,项目启动访问不到图片的问题。
  10. Linux shell 提取文件名和目录名的一些方法(转)