Description

Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
    Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.

Input

Each line has two numbers n and b,1<=n<=1000000,2<=b<=500

Output

The answer,a number per line.

Sample Input

5 10
4 10

Sample Output

10
0

Hint

#include<stdio.h>

int main()
{
int n,b;
while(scanf("%d%d",&n,&b)!=EOF)
{
int i=1;
while(n>b*i) i++;
int temp1=b*i;
int temp2=b*(i-1);
if(temp1-n>n-temp2)
printf("%d\n",temp2);
else
printf("%d\n",temp1);
}
return 0;
}
/**********************************************************************
Problem: 1040
User: song_hai_lei
Language: C++
Result: AC
Time:0 ms
Memory:1120 kb
**********************************************************************/

最新文章

  1. SharePoint 2013 设置网站集为”只读”
  2. linux 让程序在后台运行的几种可靠方法
  3. mysql 查询优化
  4. 使用D3绘制图表(4)--面积图表
  5. iOS开发——项目篇—高仿百思不得姐
  6. 关于Javascript splice方法的一个坑。
  7. 当 IDENTITY_INSERT 设置为 OFF 时,不能为表‘XXX’中的标识列插入显式值。
  8. 几款python集成开发环境
  9. (PowerShell) Managing Windows Registry
  10. JavaScript 教程学习进度备忘(二)
  11. Mysql中关于 group_concat函数详解
  12. 判断webpart类型 How can I tell what type a web part is?
  13. 产品设计中先熟练使用铅笔 不要依赖Axure
  14. Java 接口和抽象类差别
  15. win32加载图片获得像素值
  16. Nyoj Fire Station
  17. java-并发解决方案
  18. Interactive map of Linux kernel
  19. zookeeper 介绍与集群安装
  20. 简易RPC框架-SPI

热门文章

  1. Maven和Gradle中配置单元测试框架Spock
  2. IDEA中WEB项目本地调试和发布的配置分开配置
  3. SpingBoot之集成Redis集群
  4. 如何在当前文件夹打开cmd(基于win10)
  5. 力扣(LeetCode)4的幂 个人题解
  6. 安装Fedora后
  7. 移动端自动化测试Appium环境搭建(part1-2-3)
  8. 0MQ底层队列设计
  9. 2019-9-19:渗透测试,基础学习,html常用标签,笔记
  10. 图解 Spring:HTTP 请求的处理流程与机制【3】