<span style="color:#330099;">/*
F - 广搜 基础
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit Status
Description
Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected objects. The digitized slides will be represented by a rectangular grid of periods, '.', indicating empty space, and the capital letter 'X', indicating part of an object. Simple examples are XX Grid 1 .XXX Grid 2
XX .XXX
.XXX
...X
..X. X... An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X's overlap on an edge or corner, so they are connected. XXX
XXX Central X and adjacent X's
XXX An object consists of the grid squares of all X's that can be linked to one another through a sequence of adjacent X's. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square. The remaining X's belong to the other object. The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3. One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure at the left. The length is 18. Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear: Impossible Possible XXXX XXXX XXXX XXXX
X..X XXXX X... X... XX.X XXXX XX.X XX.X
XXXX XXXX XXXX XX.X ..... ..... ..... ..... ..X.. ..X.. ..X.. ..X.. .X.X. .XXX. .X... ..... ..X.. ..X.. ..X.. ..X.. ..... ..... ..... .....
Input
The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line, consisting of '.' and 'X' characters. The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks.
Output
For each grid in the input, the output contains a single line with the perimeter of the specified object.
Sample Input
2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0
Sample Output
8
18
40
48
8
By Grant Yuan
2014.7.14
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
#include<stack>
#include<cmath>
using namespace std;
char a[21][21];
bool mark[21][21];
int next[8][2]={1,0,0,1,-1,0,0,-1,1,1,1,-1,-1,1,-1,-1};
int sum;
int l,w;
int x2,y2;
int top,base;
typedef struct{
int x;
int y;
int f;
}node;
node q[500];
bool can(int xx,int yy)
{
if(xx>=0&&xx<l&&yy>=0&&yy<w&&a[xx][yy]=='X'&&mark[xx][yy]==0)
return 1;
return 0;
} void slove()
{ node q1;
int xx,yy;
int m,n;
while(top>=base){
xx=q[base].x;
yy=q[base].y;
for(int i=0;i<8;i++)
{
m=xx+next[i][0];
n=yy+next[i][1];
if(can(m,n)){
q1.x=m;
q1.y=n;
q1.f=base;
q[++top]=q1;
mark[m][n]=1;
if(i<4) sum=sum+2;
else{
if(a[xx][n]=='X'&&a[m][yy]=='X')
sum=sum;
else if(a[xx][n]=='X'||a[m][yy]=='X')
sum=sum+2;
else sum=sum+4;}
} }
base++; }}
int main()
{ node q1;
while(1){
memset(mark,0,sizeof(mark));
cin>>l>>w>>x2>>y2;
top=-1;
base=0;
if(l==0&&w==0&&x2==0&&y2==0)
break;
x2=x2-1;
y2=y2-1;
for(int i=0;i<l;i++)
cin>>a[i];
sum=0;
if(a[x2][y2]=='.')
cout<<sum<<endl;
else{
sum=4;
q1.x=x2;
q1.y=y2;
q1.f=0;
mark[x2][y2]=1;
q[++top]=q1;
slove();
cout<<sum<<endl;
}
}
return 0;
}
</span>

最新文章

  1. [转]CTO、技术总监、首席架构师的区别
  2. python基础知识(二)
  3. Windows线程漫谈界面线程和工作者线程
  4. js插入拼接链接 --包含可变字段
  5. 自己留存:mysql full text 支持中文的一个设定
  6. c++20道面试题
  7. .net开源工作流引擎ccflow
  8. Oracle学习之Oracle 树操作(select…start with…connect by…prior)
  9. VC获取屏幕分辨率大小
  10. 几个SQL语句笔试题
  11. Linux系统使用-CentOS7 for Redis
  12. Django ORM创建数据库
  13. Vue语法学习第四课(1)——组件简单示例
  14. 日志管理中获取浏览器、操作系统、IP等信息。。。
  15. PDF如何设置书签,怎么在PDF上添加书签
  16. Java虚拟机(一)结构原理与运行时数据区域
  17. POJ1644状态转移的思想——排列组合
  18. 带有logo的二维码
  19. Codeforces Round #371 (Div. 2) A ,B , C 水,水,trie树
  20. vue中的过滤器

热门文章

  1. PAT甲级考前整理(2019年3月备考)之二,持续更新中.....
  2. Python+selenium学习(二) selenium 定位不到元素
  3. canvas一周一练 -- canvas绘制中国银行标志(4)
  4. HDU_1556_线段树区间更新
  5. 用 webpack 实现持久化缓存
  6. JavaScipt30(第二个案例)
  7. Linux(Centos7) 设置静态IP
  8. 关于DOS-BOX的使用方法
  9. 扒一扒PROMISE的原理,大家不要怕!
  10. 验证DNS解析失败:解决办法之一