Calendar
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12546   Accepted: 4547

Description

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system. 

According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap
years, but 1600, 2000, and 2400 are leap years. 

Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed. 

You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include <stdio.h>
#include<string.h>
#include<math.h>
char week[7][10]= {"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
int year[2]= {365,366};
int month[2][12]= {31,28,31,30,31,30,31,31,30,31,30,31,31,29,31,30,31,30,31,31,30,31,30,31};
int type(int m)
{
if(m%4!=0||(m%100==0&&m%400!=0))
return 0;
else return 1;
}
int main()
{
int days,dayofweek;
int i=0,j=0;
while(scanf("%d",&days)!=EOF&&days!=-1)
{
dayofweek=days%7;
for(i=2000; days>=year[type(i)]; i++)
days-=year[type(i)];
for(j=0; days>=month[type(i)][j]; j++)
days-=month[type(i)][j];
printf("%d-%02d-%02d %s\n",i,j+1,days+1,week[dayofweek]);
}
return 0;
}

最新文章

  1. SAP ERP和ORACLE ERP的区别是哪些?
  2. [转]Maven实现直接部署Web项目到Tomcat7
  3. java中重载、覆盖和隐藏三者的区别分析
  4. groovy
  5. TImageList 和 TlistView 组件(C++Builder)
  6. Android手机平板两不误,使用Fragment实现兼容手机和平板的程序
  7. 20160720-java高并发
  8. Linux/Unix shell 脚本监控磁盘可用空间
  9. java 科学计数法表示转换
  10. 编码的秘密(python版)
  11. C++格式化输出的好东西
  12. [数据分析工具] Pandas 功能介绍(一)
  13. 从壹开始 [ Id4 ] 之二║ 基础知识集合 &amp; 项目搭建一
  14. 简单了解request与response
  15. svg---基础1
  16. 个人整理的数组splay板子,指针的写的太丑了就不放了。。
  17. 美团外卖app可行性分析
  18. ORACLE SQL 函数 INITCAP()
  19. python之路---07 join() fromkeys() 深浅拷贝
  20. jmeter使用HTTP代理服务器

热门文章

  1. 启发式合并CodeForces - 1009F
  2. Spring接收web请求参数的几种方式
  3. noi.ac NOIP2018 全国热身赛 第二场 T3 color
  4. 集训第五周动态规划 D题 LCS
  5. C#上位机开发(四)—— SerialAssistant功能完善
  6. Qt Widgets Application可执行程序发布方式
  7. Spring Data JPA 之 一对一,一对多,多对多 关系映射
  8. Path Sum(参考别人,二叉树DFS)
  9. Linux下启用IP转发功能(主要针对Ubuntu的使用)
  10. Java随机生成常用汉字验证码