N - Pushing Boxes

Time Limit:2000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Submit  Status

Description

Imagine you are standing inside a two-dimensional maze composed of square cells which may or may not be filled with rock. You can move north, south, east or west one cell at a step. These moves are called walks. 
One of the empty cells contains a box which can be moved to an adjacent free cell by standing next to the box and then moving in the direction of the box. Such a move is called a push. The box cannot be moved in any other way than by pushing, which means that if you push it into a corner you can never get it out of the corner again.

One of the empty cells is marked as the target cell. Your job is to bring the box to the target cell by a sequence of walks and pushes. As the box is very heavy, you would like to minimize the number of pushes. Can you write a program that will work out the best such sequence? 

Input

The input contains the descriptions of several mazes. Each maze description starts with a line containing two integers r and c (both <= 20) representing the number of rows and columns of the maze.

Following this are r lines each containing c characters. Each character describes one cell of the maze. A cell full of rock is indicated by a `#' and an empty cell is represented by a `.'. Your starting position is symbolized by `S', the starting position of the box by `B' and the target cell by `T'.

Input is terminated by two zeroes for r and c. 

Output

For each maze in the input, first print the number of the maze, as shown in the sample output. Then, if it is impossible to bring the box to the target cell, print ``Impossible.''.

Otherwise, output a sequence that minimizes the number of pushes. If there is more than one such sequence, choose the one that minimizes the number of total moves (walks and pushes). If there is still more than one such sequence, any one is acceptable.

Print the sequence as a string of the characters N, S, E, W, n, s, e and w where uppercase letters stand for pushes, lowercase letters stand for walks and the different letters stand for the directions north, south, east and west.

Output a single blank line after each test case. 

Sample Input

1 7
SB....T
1 7
SB..#.T
7 11
###########
#T##......#
#.#.#..####
#....B....#
#.######..#
#.....S...#
###########
8 4
....
.##.
.#..
.#..
.#.B
.##S
....
###T
0 0

Sample Output

Maze #1
EEEEE Maze #2
Impossible. Maze #3
eennwwWWWWeeeeeesswwwwwwwnNN Maze #4
swwwnnnnnneeesssSSS
很经典的双重搜索,要注意,当箱子的步数相等时,人走的步数要越少
#include<iostream>
#include<stdio.h>
#include<string>
#include<string.h>
using namespace std;
int n,bp,m,bx,by,add,maxbox,maxstep,allstep,ret,gx,gy,rx,ry,map[25][25],boxdir[4][2]={{0,-1},{1,0},{0,1},{-1,0}},visit[25][25],peoplevisit[25][25];
struct tree2{int i,bp,add;}setqueue[4];
struct tree{int pre,step,allstep,bx,by,rx,ry;string re;}boxq[60000],peopleq[60000];
char peoplewesn(int i)
{
if(i==0)
return 'w';
else if(i==1)
return 's';
else if(i==2)
return 'e';
else if(i==3)
return 'n';
return 'a';
}
int peoplebfs(int sx,int sy,int ex,int ey)
{ memset(peoplevisit,0,sizeof(peoplevisit));
int t,w,x,y,i,xx,yy;
t=w=1;
peopleq[1].step=0;
peopleq[1].pre=-1;
peopleq[1].allstep=0;
peopleq[1].bx=ex;//在peopleq中用bx by存人要走的地方
peopleq[1].by=ey;
peopleq[1].rx=sx;
peopleq[1].ry=sy;
peopleq[1].re="";
peoplevisit[sx][sy]=1;
if(sx==ex&&sy==ey)
{
bp=1;
add=2;
return 2;
}
while(t<=w)
{
x=peopleq[t].rx;
y=peopleq[t].ry;
if(x==ex&&y==ey)
{ bp=t;
//printf("true");
add=1;
return 1;
}
for(i=0;i<4;i++)
{
xx=x+boxdir[i][0];//人和箱子一个方向
yy=y+boxdir[i][1];
if((!peoplevisit[xx][yy])&&(map[xx][yy]==0)&&(xx>=1)&&xx<=n&&yy>=1&&yy<=m)
{
// printf("%d i\n",i);
peoplevisit[xx][yy]=1;//标记为访问
peopleq[++w].pre=t;
peopleq[w].rx=xx;
peopleq[w].ry=yy;
peopleq[w].bx=ex;
peopleq[w].by=ey;
peopleq[w].re=peopleq[t].re+peoplewesn(i);
peopleq[w].step=peopleq[t].step+1; } }
t++;
// printf("%d w%d\n",t,w);
}
// printf("%d %d false\n",t,w);
add=0;
return 0; }
bool boxcan(int x,int y,int i,int tt)//判断是否能走,并搜索人
{
int xx,yy; xx=x+boxdir[i][0];
yy=y+boxdir[i][1]; map[x][y]=1;
if((visit[xx][yy]==0)&&(map[xx][yy]==0)&&xx>=1&&xx<=n&&yy>=1&&yy<=m&&peoplebfs(boxq[tt].rx,boxq[tt].ry,x-boxdir[i][0],y-boxdir[i][1])) {
// printf("%d %d tt%d",tt,boxq[tt].rx,boxq[tt].ry);
visit[xx][yy]=1;//标记为已访问
map[x][y]=0;
return true;
}
map[x][y]=0;
return false ;
}
char boxwesn(int i)//判断箱子走的方向
{
if(i==0)
return 'W';
else if(i==1)
return 'S';
else if(i==2)
return 'E';
else if(i==3)
return 'N';
return 'a';
}
int boxbfs(int sx,int sy,int ex,int ey)//找箱子的最短路
{
memset(visit,0,sizeof(visit));
int t,w,x,y,i;
t=w=1;
boxq[1].pre=-1;
boxq[1].step=0;
boxq[1].bx=sx;
boxq[1].by=sy;
visit[sx][sy]=1;
boxq[1].re="";
boxq[1].rx=rx;
boxq[1].ry=ry;
boxq[1].allstep=0;
maxbox=-1; if(sx==ex&&sy==ey)
{
return 2; }
while(t<=w)
{
x=boxq[t].bx;
y=boxq[t].by;
if(ret==2&&boxq[t].step>maxstep)
{ return maxbox;
}
if(x==ex&&y==ey)//找到结果,但这里不能停,要把所有的是最小步数的搜出来,并把最小人走的数输出来
{
if(ret==1)
{
ret=2;
maxstep=boxq[t].step;
allstep=boxq[t].allstep;
maxbox=t;
}
if(ret==2&&boxq[t].allstep<allstep)
{
maxbox=t;
allstep=boxq[t].allstep; }
}
int j;
for(i=0,j=0;i<4;i++)//4个方向搜
{
if(boxcan(x,y,i,t))
{
{
w++;
boxq[w].pre=t;
boxq[w].bx=x+boxdir[i][0];
boxq[w].by=y+boxdir[i][1];
boxq[w].rx=x;
boxq[w].ry=y; boxq[w].step=boxq[t].step+1;
boxq[w].allstep=boxq[t].allstep+peopleq[bp].step;
if(add==2)//判定是否跟着箱子走
boxq[w].re=boxq[t].re+boxwesn(i);////结果保存下来
else if(add==1)
boxq[w].re=boxq[t].re+peopleq[bp].re+boxwesn(i);
}
} } t++; }
if(ret==2)//如果有了最小值要标记下来
return 1;
return -1;//不可达到
}
int main ()
{
int i,j,tcase=1;
char c,str[200];
while(scanf("%d%d",&n,&m)!=EOF)
{
getchar();
ret=1;maxbox=-1;maxstep=-1;allstep=-1;
if(n==0&&m==0)
break;
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
c=getchar();
if(c=='#')
map[i][j]=1;
else if(c=='.')
map[i][j]=0;
else if(c=='B')
{
map[i][j]=0;
bx=i;
by=j;
}
else if(c=='T')
{
map[i][j]=0;
gx=i;
gy=j;
}
else if(c=='S')
{
map[i][j]=0;
rx=i;
ry=j;
}
}
gets(str);
} printf("Maze #%d\n",tcase++);
if(boxbfs(bx,by,gx,gy)==-1)
{
printf("Impossible.\n\n");
}
else
{
cout<<boxq[maxbox].re<<endl<<endl;
} } return 0;
}

最新文章

  1. 推荐10款免费的在线UI测试工具
  2. C# 调用restful服务开源库
  3. 【BZOJ 2038】【2009 国家集训队】小Z的袜子(hose) 分块+莫队
  4. Linux process authority、the security risks in running process with high authority
  5. Deep Learning(深度学习)学习笔记整理
  6. jsp学习--基本语法和基础知识
  7. C# 学习笔记03 DataTable
  8. 深度学习String、StringBuffer、StringBuilder
  9. python3下的super()
  10. c#利用HttpWebRequest获取网页源代码
  11. Xcode7.3.1真机调试ios10
  12. python语言学习4——使用文本编辑器
  13. Cocos2dx 3.1.1 学习笔记整理(4):事件监听与Action的初步使用
  14. 浅谈Ajax 异步的几点细节
  15. Pythoy 数据类型序列化——json&amp;pickle 模块
  16. return的作用
  17. perl 里面如何写出阅读友好的代码提示
  18. JS高程研读记录一【事件流】
  19. Docker(十一)-Docker commit创建镜像
  20. NPM install 中:-save 、 -save-dev 和 没有--save的情况

热门文章

  1. Silverlight 雷达图和一种特殊泡泡画法
  2. JS模块与命名空间的介绍
  3. 如何让Gridview在没有数据的时候显示表头(asp.net)
  4. Mybatis包分页查询java公共类
  5. OCP-1Z0-051-题目解析-第10题
  6. Spring IOC之Bean 概述
  7. 我的Android 4 学习系列之创建用户基本界面
  8. 引用动态链接库Dll文件 引用失败 未能添加对HD.dll的引用。请确保此文件可访问并且是一个有效的程序集或COM组件
  9. iOS基础 - CALayer
  10. 附加被分离DB