Balls Rearrangement

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 344    Accepted Submission(s): 165

Problem Description
Bob has N balls and A boxes. He numbers the balls from 0 to N-1, and numbers the boxes from 0 to A-1. To find the balls easily, he puts the ball numbered x into the box numbered a if x = a mod A.

Some day Bob buys B new boxes, and he wants to rearrange the balls from the old boxes to the new boxes. The new boxes are numbered from 0 to B-1. After the rearrangement, the ball numbered x should be in the box number b if x = b mod B.

This work may be very boring, so he wants to know the cost before the rearrangement. If he moves a ball from the old box numbered a to the new box numbered b, the cost he considered would be |a-b|. The total cost is the sum of the cost to move every ball, and it is what Bob is interested in now.
 
Input
The first line of the input is an integer T, the number of test cases.(0<T<=50)

Then T test case followed. The only line of each test case are three integers N, A and B.(1<=N<=1000000000, 1<=A,B<=100000).
 
Output
For each test case, output the total cost.
 
Sample Input
3
1000000000 1 1
8 2 4
11 5 3
 
Sample Output
0
8
16
 
Source
/*分析:对于i%a - i%b,每次加上从i开始和这个值(i%a - i%b)相等的一段,
这样i就不是每次+1,而是每次加上一段,如果碰到n大于a,b的最小公倍数,
则只需要计算a,b最小公倍数长度的总和,然后sum*=n/per + p;//p表示前i个数,p=n%per; 本题反思:刚开始自己就是这样想,但是想到a,b的最小公倍数可能很大,而且n也很大,
如果刚好碰到n<per但是n很大;//per表示a,b最小公倍数,或者碰到n>per但是per很大
即使一段段的算也可能超时,所以一直不敢下手,一直在找寻更简单的推论。。结果一直没找到
下次碰到这种情况应该先试试,不能找不出别的更简单的方法就连自己想到的方法都不试试 现在认真分析发现时间复杂度好像是:O((a/b * min(per,n)/a));//假设a>=b
*/
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<cmath>
#include<math.h>
#include<iomanip>
#define INF 99999999
using namespace std; const int MAX=10;
__int64 p; __int64 Gcd(__int64 a,__int64 b){
if(b == 0)return a;
return Gcd(b,a%b);
} __int64 calculate(__int64 n,__int64 a,__int64 b,__int64 num){
p=0;
__int64 la=a,lb=b,sum=0,l;
for(__int64 i=0;i<n;){
l=min(la,min(lb,n-i));
if(i+l>num && i<num)p=sum+abs((int)(i%a - i%b))*(num-i);
sum+=abs((int)(i%a - i%b))*l;
i+=l;
la=(la-l+a-1)%a+1;
lb=(lb-l+b-1)%b+1;
}
return sum;
} int main(){
__int64 n,a,b,t;
scanf("%I64d",&t);
while(t--){
scanf("%I64d%I64d%I64d",&n,&a,&b);
__int64 gcd=Gcd(a,b),per=a*b/gcd,k=min(per,n);//求出最小公倍数
__int64 sum=calculate(k,a,b,n%k);
if(n>per)sum=(n/per)*sum+p;//p表示前n%k个i%a-i%b的和
printf("%I64d\n",sum);
}
return 0;
}

最新文章

  1. IOS-Hybrid(混合开发)
  2. PostgreSQL保存文件到数据库
  3. 使用Visual Studio调试用户模式进程(Debugging a User-Mode Process Using Visual Studio)
  4. NHibernate系列文章目录
  5. 脚本tips
  6. bootstrap-validator验证问题总结
  7. #敏捷个人资料# 免费下载 《敏捷个人-认识自我,管理自我 v0.8.pdf》
  8. gulp.watch监听文件
  9. 根据SVN的MESSAGE进行多版本输出,反向排序,真是曲折~~~啊
  10. ASP.NET Core中使用GraphQL - 第一章 Hello World
  11. 静态代码扫描之阿里java代码规范IDEA插件
  12. 改善JAVA代码01:考虑静态工厂方法代替构造器
  13. SVN怎么触发Jenkins自动构建
  14. vue axios请求/响应拦截器
  15. 解决org.apache.rat:apache-rat-plugin:0.8:check (default) on project hbase: Too many unapproved license
  16. 全方位Bindind分析
  17. POJ-1160 Post Office (DP+四边形不等式优化)
  18. 【RF库Collections测试】Get Slice From List
  19. 进程间通讯-3(Manager)-实现数据的同时修改
  20. JSON 弹窗

热门文章

  1. 查询sql 语句的好坏
  2. MongoDB shell常用命令
  3. foreach学习笔记
  4. Java学习笔记51:数组转ArrayList和ArrayList转数组技巧
  5. (step8.2.4)hdu 1846(Brave Game——巴什博奕)
  6. CoreAnimation —— CALayer
  7. Swift主题色顶级解决方案一
  8. iOS开发进阶之 UIWebView
  9. JSONP跨域的原理解析[转]
  10. 转: Firefox 浏览器对 TABLE 中绝对定位元素包含块的判定有错误