题目

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L. Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 diferent paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, …, An} is said to be greater than sequence {B1, B2, …, Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, … k, and Ak+1 > Bk+1.

Sample Input:

20 9 24

10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2

00 4 01 02 03 04

02 1 05

04 2 06 07

03 3 11 12 13

06 1 09

07 2 08 10

16 1 15

13 3 14 16 17

17 2 18 19

Sample Output:

10 5 2 7

10 4 10

10 3 3 6 2

10 3 3 6 2

题目分析

已知非叶子节点的所有子节点,已知每个节点的权重,已知一个权重和S,求权重和等于S的路径(该路径必须是从root到叶子节点)

注:多个满足条件的路径,必须非升序打印,序列A>序列B的条件为:A1Ai与B1Bi相等,但是Ai+1>Bi+1

解题思路

  1. 定义节点结构体(权重:w,子节点cds),int path[n]记录从root到当前节点路径
  2. 题目要求权重非增序输出,每个节点的所有节点信息输入完成后,对所有子节点进行排序(权重由大到小,权重最大的节点排在最左边),深度优先遍历时会从最左边路径开始,可保证最后输出的路径满足非升序条件
  3. dfs深度优先遍历树,参数numNode记录当前path中元素的个数,参数sum记录从root到当前节点的权重和

    3.1 若权重和>s,退出不再处理该路径

    3.2 若权重和==s

    3.2.1 若当前节点是叶子节点,打印路径

    3.2.2 若当前节点是非叶子节点,退出不再处理该路径

Code

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=101;
int s,path[maxn];
struct node {
int w;
vector<int> cds;
} nds[maxn];
bool cmp(int a,int b) {
return nds[a].w>nds[b].w;
}
// index当前处理节点在nds中的下标,numNode当前path数组中元素个数,sum从root到当前节点权重和
void dfs(int index, int numNode, int sum) {
if(sum>s)return; //权重和超过s
if(sum==s) {
if(nds[index].cds.size()!=0)return; //权重和为s,但不是叶子节点
//满足条件,权重和为s,且为叶子节点
for(int i=0; i<numNode; i++) {
if(i!=0)printf(" ");
printf("%d",nds[path[i]].w);
if(i==numNode-1)printf("\n");
}
return;
}
for(int i=0; i<nds[index].cds.size(); i++) {
int cdi = nds[index].cds[i]; //子节点在nds中的下标
path[numNode] = cdi;
dfs(cdi, numNode+1, sum+nds[cdi].w);
}
}
int main(int argc,char * argv[]) {
int n,m,cn,id,cid;
scanf("%d %d %d",&n,&m,&s);
for(int i=0; i<n; i++) {
scanf("%d",&nds[i].w);
}
for(int i=0; i<m; i++) {
scanf("%d %d",&id,&cn);
for(int j=0; j<cn; j++) {
scanf("%d",&cid);
nds[id].cds.push_back(cid);
}
sort(nds[id].cds.begin(),nds[id].cds.end(),cmp);
}
path[0]=0;
dfs(0,1,nds[0].w);
return 0;
}

最新文章

  1. Tomcat:配置SSL
  2. 为C#自定义控件添加自定义事件
  3. mysql 常用语句
  4. ZooKeeper 配置
  5. js 小数相加
  6. Android高效加载大图、多图解决方案,有效避免程序OOM
  7. C语言学习011:带参数的main函数
  8. 【代码笔记】iOS-点击出现选择框
  9. 来个linq to js
  10. hdu1241 Oil Deposits
  11. (个人)读取A.CSV修改它的某列,写入B.CSV
  12. PHP- 深入PHP、Redis连接
  13. BGP学习笔记
  14. VBScript - CUD registry key and value
  15. LINUX防火墙firewall、iptables
  16. Android如何在Framework层使用解锁代码
  17. ESP8266使用详解--基于Lua脚本语言
  18. android UI布局
  19. Snapman系统中TCC执行效率和C#执行效率对比
  20. ubuntun 18.04 安装和配置mysql数据库

热门文章

  1. 吴裕雄--天生自然java开发常用类库学习笔记:线程操作案例——生产者与消费者
  2. 吴裕雄 Bootstrap 前端框架开发——Bootstrap 字体图标(Glyphicons):glyphicon glyphicon-signal
  3. Golang的选择结构-if语句
  4. Day4-T4
  5. 小程序填坑:2018最新getPhoneNumber功能详解
  6. Power BI Premium
  7. 【转】美团 MySQL 数据实时同步到 Hive 的架构与实践
  8. 第十篇 Form表单
  9. category添加属性
  10. intellij idea 怎么全局搜索