Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2653    Accepted Submission(s): 795


Problem Description
Harry: "But Hagrid. How am I going to pay for all of this? I haven't any money." 

Hagrid: "Well there's your money, Harry! Gringotts, the wizard bank! Ain't no safer place. Not one. Except perhaps Hogwarts." 

— Rubeus Hagrid to Harry Potter. 

  Gringotts Wizarding Bank is the only bank of the wizarding world, and is owned and operated by goblins. It was created by a goblin called Gringott. Its main offices are located in the North Side of Diagon Alley in London, England. In addition to storing money
and valuables for wizards and witches, one can go there to exchange Muggle money for wizarding money. The currency exchanged by Muggles is later returned to circulation in the Muggle world by goblins. According to Rubeus Hagrid, other than Hogwarts School
of Witchcraft and Wizardry, Gringotts is the safest place in the wizarding world.

  The text above is quoted from Harry Potter Wiki. But now Gringotts Wizarding Bank is not safe anymore. The stupid Dudley, Harry Potter's cousin, just robbed the bank. Of course, uncle Vernon, the drill seller, is behind the curtain because he has the most
advanced drills in the world. Dudley drove an invisible and soundless drilling machine into the bank, and stole all Harry Potter's wizarding money and Muggle money. Dumbledore couldn't stand with it. He ordered to put some magic lights in the bank rooms to
detect Dudley's drilling machine. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1).....
A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Dudely's machine can only pass the vulnerable rooms. So lights must be put to light up all vulnerable rooms. There are at most fifteen vulnerable rooms in the bank. You can at most put one light
in one room. The light of the lights can penetrate the walls. If you put a light in room (x,y), it lights up three rooms: room (x,y), room (x-1,y) and room (x,y+1). Dumbledore has only one special light whose lighting direction can be turned by 0 degree,90
degrees, 180 degrees or 270 degrees. For example, if the special light is put in room (x,y) and its lighting direction is turned by 90 degrees, it will light up room (x,y), room (x,y+1 ) and room (x+1,y). Now please help Dumbledore to figure out at least how
many lights he has to use to light up all vulnerable rooms.

  Please pay attention that you can't light up any indestructible rooms, because the goblins there hate light. 

 

Input
  There are several test cases.

  In each test case:

  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 200).

  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, and '.' means a vulnerable room. 

  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of lights which Dumbledore needs to put.

  If there are no vulnerable rooms, print 0.

  If Dumbledore has no way to light up all vulnerable rooms, print -1.
 

Sample Input

2 2
##
##
2 3
#..
..#
3 3
###
#.#
###
0 0
 

Sample Output

0
2
-1
 
这题可以用状压的思想做,因为题目中说要照明的点的个数不超过15个,所以可以枚举所有情况,复杂度为4*15*(2^15)*10,是可以接受的。先枚举特殊的灯以及其放的位置,然后枚举其余灯放其他点的状态,看是否符合。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x7fffffff
#define maxn 205
char gra[maxn][maxn],lit[maxn][maxn],vis[maxn][maxn];
int a[30][5],c[30];
int tot; int check()
{
int i,j,x,y;
int flag=1;
for(i=1;i<=tot;i++){
x=a[i][0];
y=a[i][1];
if(lit[x][y])continue;
else flag=0;
}
return flag;
} int main()
{
int n,m,i,j,h,k;
int x1,x2,x3,y1,y2,y3,x,y,now,xx1,xx2,yy1,yy2,xx,yy,s,zt;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0 && m==0)break;
tot=0;
for(i=1;i<=n;i++){
scanf("%s",gra[i]+1);
for(j=1;j<=m;j++){
if(gra[i][j]=='.'){
tot++;
a[tot][0]=i;
a[tot][1]=j;
a[tot][2]=(1<<(tot-1) );
}
} }
if(tot==0){
printf("0\n");continue;
}
int ans=inf;
for(h=1;h<=4;h++){
for(k=1;k<=tot;k++){
for(i=1;i<=tot;i++){
vis[a[i][0] ][a[i][1] ]=0;
lit[a[i][0] ][a[i][1] ]=0;
}
x=a[k][0];
y=a[k][1];
if(h==1){
x1=x-1; y1=y;
x2=x; y2=y+1;
}
else if(h==2){
x1=x+1; y1=y;
x2=x; y2=y+1;
}
else if(h==3){
x1=x+1; y1=y;
x2=x; y2=y-1; }
else if(h==4){
x1=x-1; y1=y;
x2=x; y2=y-1 ;
} if(x1>=1 && x1<=n && y1>=1 && y1<=m){
if(gra[x1][y1]=='#')continue;
}
if(x2>=1 && x2<=n && y2>=1 && y2<=m){
if(gra[x2][y2]=='#')continue;
}
vis[x][y]=1;lit[x][y]=1;
if(x1>=1 && x1<=n && y1>=1 && y1<=m){
lit[x1][y1]=1;
}
if(x2>=1 && x2<=n && y2>=1 && y2<=m){
lit[x2][y2]=1;
} if(check()){
ans=min(ans,1);break;
} for(zt=1;zt<=(1<<tot)-1;zt++){
int s=zt;
for(i=1;i<=tot;i++){
vis[a[i][0] ][a[i][1] ]=0;
lit[a[i][0] ][a[i][1] ]=0; }
if(x1>=1 && x1<=n && y1>=1 && y1<=m){
if(gra[x1][y1]=='#')continue;
}
if(x2>=1 && x2<=n && y2>=1 && y2<=m){
if(gra[x2][y2]=='#')continue;
}
vis[x][y]=1;lit[x][y]=1;
if(x1>=1 && x1<=n && y1>=1 && y1<=m){
lit[x1][y1]=1;
}
if(x2>=1 && x2<=n && y2>=1 && y2<=m){
lit[x2][y2]=1;
}
if(s&(a[k][2] ))continue;
int wei=0;
int geshu=0;
while(s)
{
wei++;
c[wei]=s%2;
if(c[wei]==1)geshu++;
s/=2;
}
if(geshu+1>ans)continue;
int flag1=1;
for(i=1;i<=wei;i++){
if(c[i]==1){
xx=a[i][0];
yy=a[i][1];
xx1=xx-1;yy1=yy;
xx2=xx;yy2=yy+1;
if(xx1>=1 && xx1<=n && yy1>=1 && yy1<=m){
if(gra[xx1][yy1]=='#'){
flag1=0;break;
}
}
if(xx2>=1 && xx2<=n && yy2>=1 && yy2<=m){
if(gra[xx2][yy2]=='#'){
flag1=0;break;
}
}
vis[xx][yy]=1;lit[xx][yy]=1;
if(xx1>=1 && xx1<=n && yy1>=1 && yy1<=m){
lit[xx1][yy1]=1;
}
if(xx2>=1 && xx2<=n && yy2>=1 && yy2<=m){
lit[xx2][yy2]=1;
}
}
}
if(flag1){
if(check()){
ans=min(ans,geshu+1);
}
}
} }
if(ans==1)break;
}
if(ans==inf)printf("-1\n");
else printf("%d\n",ans);
}
return 0;
}



最新文章

  1. golang flag包
  2. Unrecognized attribute &#39;targetFramework&#39;. Note that attribute names are case-sensitive.
  3. nginx反向代理、让代理节点记录客户端真实IP
  4. 编写西游记人物类(XiYouJiRenWu)
  5. 数列F[19] + F[13]的值
  6. Winxp下搭建SVN服务器
  7. linux启动的过程
  8. [BZOJ 1098] [POI2007] 办公楼biu 【链表优化BFS】
  9. Mod_python: The Long Story
  10. Java泛型学习笔记--Java泛型和C#泛型比较学习(一)
  11. 【转】几点 iOS 开发技巧
  12. 【CentOS如何最小化安装】
  13. CSS的浮动和定位
  14. 底层网络技术以及IP编址
  15. Linux关闭You have new mail in /var/spool/mail/root提示
  16. 输入二进制数转换成十进制数(在cin&gt;&gt;和cin.get()上掉的坑)
  17. 使用OpenLDAP部署目录服务
  18. 自定义控件:Flag标签
  19. 为什么swift是面向协议的编程--对面向对象机制的改进
  20. QT 11 鼠标键盘事件添加

热门文章

  1. MongoDB的管理-深度长文
  2. Java开发手册之异常日志
  3. Azure Terraform(五)利用Azure DevOps 实现自动化部署基础资源
  4. 攻防世界—pwn—level0
  5. 基于Asp.Net Core 5.0依赖Quartz.Net框架编写的任务调度web管理平台
  6. logicaldisk本地磁盘管理
  7. ABP vNext 实现租户Id自动赋值插入
  8. Linux下利用ifconfig命令查看和操纵网络接口
  9. Python基础(if语句、运算符)
  10. 从零搭建TypeScript与React开发环境