Oil Deposits
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 16655   Accepted: 8917

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2 本题是经典的DFS题,利用DFS求连通块的数量,DFS利用的是递归实现
#include<iostream>
using namespace std; const int maxn = 100+5; char pic[maxn][maxn]; //图表
int m, n, idx[maxn][maxn]; //连通分量编号矩阵 //用DFS的方法为连通分量矩阵编号
void DFS(int r, int c, int id)
{
if(r<0||r>m||c<0||c>=n)return; //overload
if(idx[r][c]>0||pic[r][c]!='@')return; //no '@' or 已经访问
idx[r][c]=id; //连通分量编号
for(int dr=-1; dr<=1;dr++)
for(int dc=-1;dc<=1;dc++)
if(dr!=0||dc!=0)DFS(r+dr, c+dc, id);
} int main()
{
while(cin>>m>>n&&m!=0)
{
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
cin>>pic[i][j];
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
idx[i][j]=0;
int cnt=0;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
if(idx[i][j]==0&&pic[i][j]=='@')DFS(i,j,++cnt);
cout<<cnt<<endl;
}
return 0;
}

 

可以参考floodfill算法

https://en.wikipedia.org/wiki/Flood_fill 

												

最新文章

  1. (二)SQL Server分区创建过程
  2. 简单的验证码识别(opecv)
  3. CART
  4. jQuery选择器之基本过滤选择器Demo
  5. Thinking in java——Generics
  6. (原)C++解析XML生成类对象_v1.0 函数指针
  7. 使用SQL Server 2005 新的语法ROW_NUMBER()进行分页的两种不同方式的性能比较
  8. HeadFirst设计模式读书笔记(5)-单例模式
  9. [置顶] JNI之java传递数据给c语言
  10. ajax请求基于restFul的WebApi(post、get、delete、put)
  11. Cesium高度解析
  12. 图-&gt;最短路径-&gt;单源最短路径(迪杰斯特拉算法Dijkstra)
  13. vue 上拉加载自定义组件,超好用哦
  14. mysql-修改字段类型和修改字段名称
  15. Python学习之not,and,or篇
  16. Handler消息传递机制浅析
  17. Using promises
  18. 洛谷P2017 [USACO09DEC]晕牛Dizzy Cows [拓扑排序]
  19. Android 编程下 AlarmManager
  20. thinkphp 控制器unset删除对象变量失败。。

热门文章

  1. 通过file文件选择图片预览功能
  2. RelativeLayout各个属性
  3. js控制键盘按键(回车、空格)
  4. 循序渐进看Java web日志跟踪(3)-Log4J的使用和配置
  5. mysql vachar
  6. Linux学习初步
  7. Foxit Reader(福昕PDF阅读器) v4.3.1.218 绿色专业版
  8. 可参考的gulp资源
  9. 利用before、after制作提示框
  10. swift 中Value Type VS Class Type