Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 85 Accepted Submission(s): 53
 
Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 
Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 
Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
 
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
 
Author
ZHOU, Ran
 
Source
Zhejiang University Local Contest 2006, Preliminary
 
Recommend
linle
 
/*
题意:简单的模拟两个操作:GET获取优先级最高的,PUT压进栈东西 初步思路:优先队列,搞一下,本来想偷一下懒。把以前写的代码贴上,结果死活不对。
*/
#include<bits/stdc++.h>
using namespace std;
struct node{
string name;
int val;
int Rank;
int time;
node(){}
node(string a,int b,int c,int d){
name=a;
val=b;
Rank=c;
time=d;
}
bool operator < (const node &other) const{
if(Rank==other.Rank)
return time>other.time;
return Rank>other.Rank;
}
};
priority_queue<node> Message;
string op;
string name;
int times=;
int val,Rank;
void init(){
times=;
while(!Message.empty()) Message.pop();
}
int main(){
// freopen("in.txt","r",stdin);
init();
while(cin>>op){
if(op=="GET"){
if(Message.empty()) puts("EMPTY QUEUE!");
else{
cout<<Message.top().name<<" "<<Message.top().val<<endl;
Message.pop();
}
}else{
cin>>name>>val>>Rank;
Message.push(node(name,val,Rank,times++));
}
}
return ;
}

最新文章

  1. html和css
  2. Java泛型学习笔记 - (二)泛型类
  3. php大力力 [050节] 兄弟连高洛峰 PHP教程 2014年[数据库、PDO教程]
  4. C#读书雷达
  5. Hibernate之N+1问题
  6. git 回退和删除操作
  7. Intent中的重要属性详解
  8. 下载文件夹里面的所有文件,并压缩成.zip压缩包的形式
  9. [LeetCode235]Lowest Common Ancestor of a Binary Search Tree
  10. 学习笔记: JavaScript/JQuery 的cookie操作
  11. C语言基础知识点整理(函数/变量/常量/指针/数组/结构体)
  12. 自建梯子教程:vultr+ssr+SwitchyOmega
  13. 【ANT】一个简单的ANT生成文件build.xml
  14. 在Bootstrap开发框架中使用bootstrap-datepicker插件
  15. python2x与python3x的区别
  16. 通过eclipse创建项目
  17. kbmmw 5.04 发布
  18. MyBatis高级篇之整合ehcache缓存框架
  19. mui框架(三)
  20. Swift语言从天而降,是否能掀起新一轮的科技革命?

热门文章

  1. shell脚本获取文件中key/value的小方法
  2. touch.js——常见应用操作
  3. LINUX通过PXE自动部署系统
  4. ThinkPHP控制器输出防止乱码小技巧
  5. MySQL之最基本命令
  6. oracle排序的几种方法
  7. WordPress-基础设置之阅读设置
  8. 邮件实现详解(二)------手工体验smtp和pop3协议
  9. Java面向对象 IO (四)
  10. Java Web开发——MySQL数据库的安装与配置