Number String

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1027 Accepted Submission(s): 448

Problem Description
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

 
Input
Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.

 
Output
For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

 
Sample Input
II
ID
DI
DD
?D
??
 
Sample Output
1
2
2
1
3
6

Hint

Permutation {1,2,3} has signature "II".
Permutations {1,3,2} and {2,3,1} have signature "ID".
Permutations {3,1,2} and {2,1,3} have signature "DI".
Permutation {3,2,1} has signature "DD".
"?D" can be either "ID" or "DD".
"??" gives all possible permutations of length 3.

 
Author
HONG, Qize
 
Source
 
Recommend
lcy
很明显的dp,我们可以得到壮态转移方程 ,如果是增dp[i][j]=sum(dp[i-1][1-j-1]),如果是减 ,我们可以 得到dp[i][j]=sum(dp[i-1][j-i-1]);这样,马上就可以得出结果了!
#include <iostream>
#include <stdio.h>
#include <string.h>
#define mod 1000000007
using namespace std;
char str[1050];
int dp[1050][1050],sum[1050][1050];
int main()
{
int i,j;
while(scanf("%s",str)!=EOF)
{
memset(dp,0,sizeof(dp));
sum[1][1]=1;
int strnum=strlen(str);
for(i=2;i<=strnum+1;i++)
{
for(j=1;j<=i;j++)
{
if(str[i-2]=='I'||str[i-2]=='?')
{ dp[i][j]=(dp[i][j]+sum[i-1][j-1])%mod;
}
if(str[i-2]=='D'||str[i-2]=='?')
{ dp[i][j]=(dp[i][j]+((sum[i-1][i-1]-sum[i-1][j-1])%mod+mod)%mod)%mod; }
sum[i][j]=(sum[i][j-1]+dp[i][j])%mod;
}
}
printf("%d\n",sum[strnum+1][strnum+1]);
}
return 0;
}

 

Statistic |
Submit |
Discuss |
Note

最新文章

  1. 基于STM32Cube的IIC主从通信
  2. MySQL 常用命令总结
  3. struts2的拦截器(Interceptor)与过滤器(Filter)
  4. A Simple MVVM Example[Forward]
  5. .NET开源工作流RoadFlow-流程设计-流程步骤设置-策略设置
  6. 总结Allegro元件封装(焊盘)制作方法[修整]
  7. Java GC 概念摘要
  8. UVA_Digit Puzzle UVA 12107
  9. C++教程之autokeyword的使用
  10. linux几条常用的命令
  11. HDU - 1907 John 反Nimm博弈
  12. SpriteBuilder中的粒子系统属性
  13. 数据库数据迁移 SqlServer复制到mysql
  14. MSSQL coalesce系统函数简介
  15. 18春季训练01-3/11 2015 ACM Amman Collegiate Programming Contest
  16. 【webdriver自动化】Python数据驱动工具DDT
  17. Android---Hellow World
  18. 【python】初识python
  19. Alpha发布评价
  20. Checkpoint--在Tempdb上的特殊性

热门文章

  1. iOS设计模式:观察者
  2. SDUT 2860-生日Party(BFS)
  3. android内存的一点优化
  4. javascript笔记整理(对象遍历封装继承)
  5. Ajax技术——带进度条的文件上传
  6. @produces在spring mvc中是什么意思
  7. could not create the java virtual machine(转)
  8. encode_utf8 把字符编码成字节 decode_utf8解码UTF-8到字符
  9. iphone开发教程下载
  10. 用Delphi实现Windows的鼠标钩子函数