Nearest Common Ancestors
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20940   Accepted: 11000

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 



 

In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor
of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node
x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common
ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 



For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest
common ancestor of y and z is y. 



Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 


Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,...,
N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers
whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

并查集。之前在hihoCoder第十二周做过类似的。

代码:

#include <iostream>
#include <vector>
#include <string>
#include <cstring>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std; int father[10005]; void result(int test1,int test2)
{
int node2=test2;
while(father[test1]!=test1)
{
node2=test2;
while(father[node2]!=node2)
{
if(test1==node2)
{
cout<<test1<<endl;
return;
}
node2=father[node2];
}
test1=father[test1];
}
cout<<test1<<endl;
return;
} int main()
{
int count;
cin>>count; while(count--)
{
int fa,son,node,i;
cin>>node; for(i=1;i<10005;i++)
{
father[i]=i;
} for(i=1;i<=node-1;i++)
{
cin>>fa>>son;
father[son]=fa;
}
int test1,test2;
cin>>test1>>test2; result(test1,test2);
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. Liferay7 BPM门户开发之47: 集成Activiti待办已办任务清单和流程启动
  2. 乐视云计算基于OpenStack的IaaS实践
  3. VS2010下配置使用OpenGL的glut库
  4. linux程序调试常用命令
  5. 【python】python+behave自动化
  6. CodeForces 558E(计数排序+线段树优化)
  7. hadoop数据[Hadoop] 实际应用场景之 - 阿里
  8. C# 学习笔记01
  9. 递归回溯 UVa140 Bandwidth宽带
  10. 如何使用纯CSS制作特效导航条?
  11. 从零开始打jar包--补充
  12. 五.JQuary 实例
  13. 饮冰三年-人工智能-Python-15Python基础之文件处理
  14. 使用SQL语句如何实现条件判断
  15. Python 字符串中 startswith()方法
  16. gulp安装,淘宝镜像
  17. (C/C++学习笔记) 十. 函数
  18. 测试开发系列之Python开发mock接口(一)
  19. Java新人拿到一台新的电脑需要装配什么
  20. Android组件化框架项目详解

热门文章

  1. python爬虫处理在线预览的pdf文档
  2. Using SmartAssembly with MSBuild
  3. unittest---unittest数据驱动(ddt)
  4. SSM(Spring-SpringMvc-Mybatis)练习
  5. 认识iOS系统架构
  6. linux磁盘扩容常见问题
  7. 【剑指Offer面试编程题】题目1510:替换空格--九度OJ
  8. C语言入门第四章
  9. Linux命令:ls命令
  10. sdfsdsf