Expanding Rods
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13780   Accepted: 3563

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 



Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod
expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

题意是一根长度为L的木棒,加热n度之后长度变为L'=(1+n*C)*L,其中C是木棒的热膨胀系数。给出L,n,C。求木棒在加热前后中心点的距离是多少。

四个方程:(假设要求的距离为x)

L'=(1+n*C)*L

θr = 1/2*L'

sinθ= 1/2*L/r

r*r = (1/2*L)*(1/2*L) + (r-x)*(r-x)

这个题目有意思的地方在于导出x非常困难,所以只能枚举x的值,然后能够得到r的值,然后去带入方程2 3,去和正确值比较。导出最终的函数是一个单调性函数,所以直接二分。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; #define esp 1e-5 double L, N, C, S; bool check(double mid)
{
double ans = 2 * asin((L / 2) / ((L*L + 4 * mid*mid) / (8 * mid)))*((L*L + 4 * mid*mid) / (8 * mid));
return ans >= S;
} int main()
{
//freopen("i.txt","r",stdin);
//freopen("o.txt","w",stdout); double left, right, mid; while (cin>>L>>N>>C)
{
if (L + N + C < 0 )
break;
S = (1 + N*C)*L;
left = 0.0;
right = L/2; while (right - left > esp)
{
mid = (right + left) / 2;
if (check(mid))
{
right = mid;
}
else
{
left = mid;
}
}
printf("%.3lf\n",right);
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

最新文章

  1. iOS系列教程 目录 (持续更新...)
  2. SQL Server 求结果
  3. Python之路-python(css布局、JavaScript)
  4. MFC 响应控件消息
  5. Duplicate id @+id/imageView, already defined earlier in this layout,android
  6. JAVA设计模式 之 策略模式
  7. 笔记一、Git服务器【转】
  8. JVM——垃圾收集器
  9. asp.net中web.config配置节点大全详解【转】
  10. CentOS7安装性能监控系统
  11. POJ1323-Game Prediction
  12. Raphael入门实例:动画与箭头
  13. iOS开发讯飞语音的集成
  14. 坚持自己的追求,迎来 “中国系统开发网” (CSDN)的专访
  15. 4.16 反射和jvm
  16. Java 学习笔记 线程控制
  17. A2D Framework - 看如何精简业务逻辑 - 缓存子系统
  18. vs2010安装的一些问题
  19. [LeetCode解题报告] 703. 数据流中的第K大元素
  20. 072 HBase的架构以及各个模块的功能

热门文章

  1. Java-用星号打印菱形
  2. Python 之并发编程之进程中(守护进程(daemon)、锁(Lock)、Semaphore(信号量))
  3. 更换JAVA程序的界面风格
  4. winform跳转到bs
  5. 【剑指Offer面试编程题】题目1511:从尾到头打印链表--九度OJ
  6. Kotlin 学习 (一)
  7. sass计算高度
  8. 六 Hibernate多表操作&amp;级联&amp;外键维护
  9. 基于 QEMU进行 arm 仿真开发 (以 vexpress-a9 为例)
  10. jenkins -- 安装、任务构建