Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 103000    Accepted Submission(s): 39524

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 
 
Sample Output
red
pink
 

先上题意:

首先输入数据个数n,以下n行输入n个字符串表示气球颜色,输出出现次数最多的颜色。

本题也是做过好久的老题了,上次我们探讨的是用字符串比较函数strcmp()来比较两字符串是否相等从而判断出现次数(见这里)。这次我们用map映照容器来重新做一下这个题目。

用map容器相对来说就要简单一些,每当输入相应的颜色,与之相对应的数值就+1,最后再输出最大数值最大的颜色就好。

附AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std; int main(){
map<string,int> Bollon;//定义map容器
string Color,Maxcolor;
int n;
while(~scanf("%d",&n)&&n!=){
Bollon.clear();//每次处理下一组数据前要清空容器
while(n--){//输入气球颜色,相应颜色气球个数加一
cin>>Color;
Bollon[Color]++;
}
int max=;
map<string,int>::iterator it;//定义前向迭代器,向前遍历容器
for(it=Bollon.begin();it!=Bollon.end();it++){
if(it->second>max){//不知为何换成it.second就编译不过
max=it->second;
Maxcolor=it->first;//找出个数最多的气球颜色
}
}
cout<<Maxcolor<<endl;
}
return ;
}

最新文章

  1. Postman - 功能强大的 API 接口请求调试和管理工具
  2. 关于docker
  3. js时间戳与日期格式之间的转换
  4. 给 VS 2010 选一个好用的代码行数统计器(转)
  5. 打造Ubuntu下Java开发环境
  6. javase基础复习攻略《一》
  7. CentOS 7.0 Nvidia显卡安装步骤
  8. RadGridView标头分行
  9. COleChangeSourceDialog不能Change Source的解决方法
  10. SharePoint 2013 列表多表联合查询
  11. mysql 查看锁表解锁
  12. Android中全局搜索(QuickSearchBox)详解
  13. POJ3080 Blue Jeans
  14. 算法笔记_014:合并排序(Java)
  15. 还原openstack配置文件的方法
  16. execlp(&quot;ls&quot;,&quot;flw&quot;,&quot;-?&quot;,(char *)0) 为什么少了最后的一个参数就不行?
  17. nginx keepalived 主从切换
  18. 初学Python(二)——数组
  19. Centos 使用yum安装MongoDB 4.0
  20. C语言博客作业04--数组

热门文章

  1. MOS简单应用
  2. Terminal emulator
  3. [单元測试]_[VC2010使用gtest单元測试入门]
  4. MVC3-表单
  5. MyBatis学习(一):简单的运行
  6. 按照HashMap中value值进行排序
  7. Android中通过GPS或NetWork获取当前位置的经纬度
  8. 九度OJ 1138:进制转换 (进制转换)
  9. Tomcat设置虚拟文件夹
  10. 解析json的方式