【POJ 2942】Knights of the Round Table(双联通分量+染色判奇环)



Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 11661   Accepted: 3824

Description

Being a knight is a very attractive career: searching for the Holy Grail, saving damsels in distress, and drinking with the other knights are fun things to do. Therefore, it is not very surprising that in recent years the kingdom
of King Arthur has experienced an unprecedented increase in the number of knights. There are so many knights now, that it is very rare that every Knight of the Round Table can come at the same time to Camelot and sit around the round table; usually only a
small group of the knights isthere, while the rest are busy doing heroic deeds around the country.



Knights can easily get over-excited during discussions-especially after a couple of drinks. After some unfortunate accidents, King Arthur asked the famous wizard Merlin to make sure that in the future no fights break out between the knights. After studying
the problem carefully, Merlin realized that the fights can only be prevented if the knights are seated according to the following two rules:

  • The knights should be seated such that two knights who hate each other should not be neighbors at the table. (Merlin has a list that says who hates whom.) The knights are sitting around a roundtable, thus every knight has exactly two neighbors.
  • An odd number of knights should sit around the table. This ensures that if the knights cannot agree on something, then they can settle the issue by voting. (If the number of knights is even, then itcan happen that ``yes" and ``no" have the same number of
    votes, and the argument goes on.)

Merlin will let the knights sit down only if these two rules are satisfied, otherwise he cancels the meeting. (If only one knight shows up, then the meeting is canceled as well, as one person cannot sit around a table.) Merlin realized that this means that
there can be knights who cannot be part of any seating arrangements that respect these rules, and these knights will never be able to sit at the Round Table (one such case is if a knight hates every other knight, but there are many other possible reasons).
If a knight cannot sit at the Round Table, then he cannot be a member of the Knights of the Round Table and must be expelled from the order. These knights have to be transferred to a less-prestigious order, such as the Knights of the Square Table, the Knights
of the Octagonal Table, or the Knights of the Banana-Shaped Table. To help Merlin, you have to write a program that will determine the number of knights that must be expelled.



Input

The input contains several blocks of test cases. Each case begins with a line containing two integers 1 ≤ n ≤ 1000 and 1 ≤ m ≤ 1000000 . The number n is the number of knights. The next m lines describe which knight hates which
knight. Each of these m lines contains two integers k1 and k2 , which means that knight number k1 and knight number k2 hate each other (the numbers k1 and k2 are between 1 and n ).




The input is terminated by a block with n = m = 0 .


Output

For each test case you have to output a single integer on a separate line: the number of knights that have to be expelled.



Sample Input

5 5
1 4
1 5
2 5
3 4
4 5
0 0

Sample Output

2

Hint

Huge input file, 'scanf' recommended to avoid TLE.

Source

题目大意:有n个骑士,m个仇视关系,每一个关系a b表示a与b老死不相往来,。

如今亚瑟王想要定期举办圆桌会议。圆桌会议要求到的骑士围成一圈。也就是每一个骑士一定会有左右两个相邻的骑士。要求相邻的骑士间不可有直接的仇视关系。

举行圆桌会议的骑士数目必须大于1。而且必须为奇数。

问须要剔除多少骑士才干正常举办会议。

有一个意思我没读出来,就是并不须要留下的骑士能參与同一场会议,会议能够举行多场,仅仅要留下的骑士能參与当中一场就可以。

这样建立补图,也就是骑士友好关系的图后。处于不同的双连通子图中的点一定无法出席同一场圆桌会议。由于这些点间要么是仇恨关系,要么仅仅有一条友好关系,无法成环。

这样范围就缩小到同一双连通分量中。

这里用到了一个结论,对于一个双连通分量,假设存在奇环,那么这个双连通分量中的每个点都一定会存在于至少一个奇环中。

由于不论什么一个点都有两条以上到这个奇环的路径,两条路径在连接奇环上的两个点,能够把奇环变为偶链和奇链 这样依据该点到这两个点间点个数的奇偶性进行选择 就保证一定能够构成奇环。

相同,假设不存在奇环,则全部双连通分量中的点都不存在于不论什么一个奇环中。

代码例如以下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout) using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8; bool can[2333];
bool in[2333];
bool mp[2333][2333];
bool vis[2333];
int col[2333];
int dfn[2333],low[2333];
stack <int> s;
int n,tim; bool cal(int u)
{
// printf("%d\n",u);
queue <int> q;
q.push(u);
memset(col,-1,sizeof(col));
col[u] = 1; while(!q.empty())
{
u = q.front();
q.pop();
for(int i = 1; i <= n; ++i)
{
if(u != i && in[i] && !mp[u][i])
{
// printf("%d->%d %d %d\n",u,i,col[u],col[i]);
if(col[i] == -1)
{
col[i] = col[u]^1;
q.push(i);
}else if(col[i] == col[u]) return true;
}
}
}
return false;
} void tarjan(int u,int pre)
{
s.push(u);
dfn[u] = low[u] = tim++;
vis[u] = 1;
for(int i = 1; i <= n; ++i)
{
if(i == u || i == pre || mp[u][i]) continue;
if(!vis[i])
{
tarjan(i,u);
low[u] = min(low[u],low[i]);
if(low[i] >= dfn[u])
{
memset(in,0,sizeof(in));
while(s.top() != i)
{
in[s.top()] = 1;
s.pop();
}
in[i] = 1;
s.pop();
in[u] = 1;
if(cal(u))
{
for(int i = 1; i <= n; ++i)
if(in[i]) can[i] = 1;
}
}
}else low[u] = min(low[u],dfn[i]);
}
} int main()
{
//fread();
//fwrite(); int m,u,v;
while(~scanf("%d%d",&n,&m) && (n+m))
{
memset(mp,0,sizeof(mp));
while(m--)
{
scanf("%d%d",&u,&v);
mp[u][v] = mp[v][u] = 1;
} memset(vis,0,sizeof(vis));
memset(can,0,sizeof(can));
tim = 0;
for(int i = 1; i <= n; ++i)
if(!vis[i]) tarjan(i,i); int ans = 0;
for(int i = 1; i <= n; ++i)
ans += can[i]; printf("%d\n",n-ans);
} return 0;
}



最新文章

  1. apache极简配置虚拟机
  2. 数据库错误:check the manual that corresponds to your MySQL server version for the right sy
  3. SQL Server中DateTime与DateTime2的区别
  4. 正则表达式验证工具类RegexUtils.java
  5. android 检测ListView滚动到的位置
  6. ubuntu12 开机自动转到命令行
  7. 从本地上传整个目录到hdfs的java程序
  8. rails第一次做项目
  9. zoj 3822 Domination(dp)
  10. linux安装gcc-c++
  11. STL系列
  12. 不错的JQuery屏幕居中提示信息封装,使用方便,可集成到项目
  13. Spring Tools4
  14. YYS FZU - 2278 (期望)JAVA
  15. python 爬虫数据处理字符串时间转换格式方法
  16. LeetCode - Most Frequent Subtree Sum
  17. (网络流 模板 Edmonds-Karp)Drainage Ditches --POJ --1273
  18. kaggle-泰坦尼克号Titanic-1
  19. xcode发布ipa
  20. day 3 局部变量 全局变量

热门文章

  1. JavaScript——视频插入
  2. 如何修改 WordPress 数据库前缀
  3. houxiurong.com 关于Tomcat7部署 一台机器部署两个项目,一个用域名访问,一个用IP访问
  4. PhotoZoom如何使用调整大小配置文件
  5. 创建一个dynamics CRM workflow (六) - Debugging Custom Workflows
  6. codeforces 468B two set(并查集)
  7. 路飞学城Python-Day114
  8. asyncio 自动跳出长时间堵塞的 task
  9. 基于Vue的事件响应式进度条组件
  10. 初步体验libsvm用法1(官方自带工具)