点击打开链接题目链接

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5023    Accepted Submission(s): 1749

Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other
kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi
Huang" means "the first emperor" in Chinese.




Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:

There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.

Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that
magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible,
but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the
total length of none magic roads.

Would you help Qin Shi Huang?

A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 
Input
The first line contains an integer t meaning that there are t test cases(t <= 10).

For each test case:

The first line is an integer n meaning that there are n cities(2 < n <= 1000).

Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.

It is guaranteed that each city has a distinct location.
 
Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 
Sample Input
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
 
Sample Output
65.00
70.00
 
Source
 
秦王想建路使每一个城市连通 有个法师能够使某一条路花费为0
法师希望这条路两边城市的人越多越好
秦王希望建路的花费最少
A代表人数B代表花费
问A/B的最大值

思路:
先用最小生成树找出花费 然后遍历全部点 假设花费为0的路正好在最小生成树的路径上
则B=sum-dis[i][j];
否则 须要找出环上最长的一条路
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define INF 0x3f3f3f3f*1.0
using namespace std;
double getdistence(int x1,int y1,int x2,int y2){
double xx=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
return xx;
}
int n;
double kill;
struct Node{
int x,y,p;
}node[1111];
bool visit[1111][1111],vis[1111];
double dis[1111][1111],path[1111][1111];
int pre[1111];
void init(){
memset(visit,0,sizeof(visit));
memset(vis,0,sizeof(vis));
memset(path,0,sizeof(path));
kill=0.0;
for(int i=1;i<=n;i++)
scanf("%d %d %d",&node[i].x,&node[i].y,&node[i].p);
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
dis[i][j]=getdistence(node[i].x,node[i].y,node[j].x,node[j].y);
}
void prim(){
double dist[1111];
vis[1]=1;
for(int i=1;i<=n;i++){
dist[i]=dis[1][i];
pre[i]=1;
}
int p,k;
p=-1;
double minn;
for(int i=1;i<n;i++){
minn=INF;
for(int j=1;j<=n;j++){
if(!vis[j]&&minn>dist[j]){
minn=dist[j];
k=j;
}
}
visit[k][pre[k]]=visit[pre[k]][k]=1;
kill+=minn;
vis[k]=1;
for(int j=1;j<=n;j++){
if(!vis[j]&&dist[j]>dis[k][j]){
dist[j]=dis[k][j];
pre[j]=k;
}
if(vis[j]&&j!=k){
path[j][k]=path[k][j]=max(path[j][pre[k]],dist[k]);
}
}
}
}
void solve(){
double ans=0.0;
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
if(j!=i){
if(visit[i][j])
ans=max(ans,(node[i].p+node[j].p)*1.0/(kill-dis[i][j]));
else
ans=max(ans,(node[i].p+node[j].p)*1.0/(kill-path[i][j]));
}
}
}
printf("%.2f\n",ans);
}
int main(){
int t;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
init();
prim();
solve();
}
return 0;
}

最新文章

  1. 移动端页面调试神器-browser-sync
  2. 常用shell 命令整理 一 进程 cpu
  3. MySQL服务 - 客户端工具mysql及mysqladmin使用介绍
  4. 转换,2D,3D
  5. IDM和ODM
  6. 查找PHP的配置文件
  7. 升级mac的java版本
  8. poi实现Excel导出
  9. Java学习—— for循环
  10. ubantu安全卸载火狐浏览器
  11. 树莓派 nfs server安装
  12. License控制解决方案
  13. 通过 CLI 管理 Jenkins Server
  14. 第16月第26天 /bin/bash^M: bad interpreter: 没有那个文件或目录
  15. 微服务之分布式跟踪系统(springboot+pinpoint)
  16. Python3玩转单链表——逆转单向链表pythonic版
  17. 项目开发--&gt;基础功能汇总
  18. 该登录名来自不受信任的域,不能与 Windows 身份验证一起使用。
  19. 【批量加入】-拼接sql字符串
  20. hibernate中dialect的讲解

热门文章

  1. git pull 跟 fetch的区别
  2. W10子系统UBantu命令安装Redis及其启动
  3. dbgview
  4. vue解决跨域问题
  5. Set&amp;Map区别Array
  6. JAVA深克隆与浅克隆1
  7. MySQL高可用系列之MHA(二)
  8. Picking up Jewels
  9. storm-安装
  10. JavaWeb错误处理集锦