题意翻译

给定一个长度为n的小写字母串。问你有多少对相交的回文子 串(包含也算相交) 。 输入格式

第一行是字符串长度n(1<=n<=2*10^6),第二行字符串 输出格式

相交的回文子串个数%51123987

Translated by liyifeng

题目描述

In an English class Nick had nothing to do at all, and remembered about wonderful strings called palindromes. We should remind you that a string is called a palindrome if it can be read the same way both from left to right and from right to left. Here are examples of such strings: «eye», «pop», «level», «aba», «deed», «racecar», «rotor», «madam».

Nick started to look carefully for all palindromes in the text that they were reading in the class. For each occurrence of each palindrome in the text he wrote a pair — the position of the beginning and the position of the ending of this occurrence in the text. Nick called each occurrence of each palindrome he found in the text subpalindrome. When he found all the subpalindromes, he decided to find out how many different pairs among these subpalindromes cross. Two subpalindromes cross if they cover common positions in the text. No palindrome can cross itself.

Let's look at the actions, performed by Nick, by the example of text «babb». At first he wrote out all subpalindromes:

• «b» — 1..1 • «bab» — 1..3 • «a» — 2..2 • «b» — 3..3 • «bb» — 3..4 • «b» — 4..4 Then Nick counted the amount of different pairs among these subpalindromes that cross. These pairs were six:

  1. 1..1 cross with 1..3
  2. 1..3 cross with 2..2
  3. 1..3 cross with 3..3
  4. 1..3 cross with 3..4
  5. 3..3 cross with 3..4
  6. 3..4 cross with 4..4

    Since it's very exhausting to perform all the described actions manually, Nick asked you to help him and write a program that can find out the amount of different subpalindrome pairs that cross. Two subpalindrome pairs are regarded as different if one of the pairs contains a subpalindrome that the other does not.

输入输出格式

输入格式:

The first input line contains integer n ( 1<=n<=2·106 ) — length of the text. The following line contains nnlower-case Latin letters (from a to z).

输出格式:

In the only line output the amount of different pairs of two subpalindromes that cross each other. Output the answer modulo 51123987 .

输入输出样例

输入样例#1: 复制

4

babb

输出样例#1: 复制

6

输入样例#2: 复制

2

aa

输出样例#2: 复制

2


题解

一道比较不错的题目。

解法和P1872 回文串计数(回文树)差不多。

我们就是先统计一遍不会相交的情况,在统计一遍所有情况。

把所有情况减去不会相交的情况就可以了。

简单吗,简单。

一交代码

然后,你就会发现,你RE了。

让我们看一手数据。

1<=n<=2·106

空间复杂度铁定GG。出题人心机婊

所以我们用邻接表来代替trie的直接储存。

以时间换空间。Orz。


代码

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;
ll tot,sum,num;
ll n,ans,p1[2000001],p2[2000001];
int head[2000001];
struct node{
int fail,len,cnt,dep;
}t[2000001];
struct nod{
int next,to,v;
}e[2000001];
char s[2000001];
const int mod=51123987;
int read()
{
int x=0,w=1;char ch=getchar();
while(ch>'9'||ch<'0'){if(ch=='-')w=-1;ch=getchar();}
while(ch>='0'&&ch<='9')x=x*10+ch-'0',ch=getchar();
return x*w;
} void link(int from,int to,int v){
num++;
e[num].to=to;
e[num].v=v;
e[num].next=head[from];
head[from]=num;
} int tr(int x,int v)
{
for(int i=head[x];i;i=e[i].next)
if(e[i].v==v)return e[i].to;
return 0;
} void solve1()
{
int len=strlen(s+1),k=0;s[0]='#';
t[0].fail=t[1].fail=1;t[1].len=-1;tot=1;
for(int i=1;i<=len;i++)
{
while(s[i-t[k].len-1]!=s[i])k=t[k].fail;
if(!tr(k,s[i]-'a')){
t[++tot].len=t[k].len+2;
int j=t[k].fail;
while(s[i-t[j].len-1]!=s[i])j=t[j].fail;
t[tot].fail=tr(j,s[i]-'a');
t[tot].dep=(t[t[tot].fail].dep+1)%mod;
link(k,tot,s[i]-'a');
}
k=tr(k,s[i]-'a');
p1[i]=(t[k].dep)%mod;
t[k].cnt++;
}
for(int i=tot;i>=2;i--)
t[t[i].fail].cnt+=t[i].cnt;
for(int i=tot;i>=2;i--)
if(t[i].len!=1)
sum+=t[i].cnt;
} void solve2()
{
int len=strlen(s+1),k=0;s[0]='#';
t[0].fail=t[1].fail=1;t[1].len=-1;tot=1;
for(int i=1;i<=len;i++)
{
while(s[i-t[k].len-1]!=s[i])k=t[k].fail;
if(!tr(k,s[i]-'a')){
t[++tot].len=t[k].len+2;
int j=t[k].fail;
while(s[i-t[j].len-1]!=s[i])j=t[j].fail;
t[tot].fail=tr(j,s[i]-'a');
t[tot].dep=(t[t[tot].fail].dep+1)%mod;
link(k,tot,s[i]-'a');
}
k=tr(k,s[i]-'a');
t[k].cnt++;
p2[len-i+1]=(t[k].dep)%mod;
}
} int main()
{
n=read();
scanf("%s",s+1);
int len=strlen(s+1);
solve1();
reverse(s+1,s+len+1);
memset(t,0,sizeof(t));
num=0;
memset(head,0,sizeof(head));
solve2();
sum%=mod;n%=mod;
for(int i=1;i<=len;i++)p1[i]+=p1[i-1],p1[i]%=mod;
for(int i=1;i<=len;i++)ans+=(p1[i]*p2[i+1])%mod,ans%=mod;
printf("%lld",(ll)((((sum+n)*(sum+n-1))/2%mod-ans)+mod)%mod);
return 0;
}

最新文章

  1. 1元搭建自己的云服务器&amp;解析域名
  2. 第一弹:Java 中创建对象的4种方式
  3. iOS小知识点(非UI部分)
  4. Jquery下拉列表添加移除数据
  5. Java集合类学习笔记(各种Map实现类的性能分析)
  6. Linux下搭建FTP服务器
  7. ng2-timesheet, 一个timesheet.js的angular2复制版
  8. [Cordova] 无法编译Visual Studio项目里Plugin副本的Native Code
  9. python之旅【第二篇】
  10. 关于mac下面用Parallels装ubuntu时分辨率问题[已解决]
  11. python中argparse模块的使用
  12. spring各个包之间的依赖关系
  13. 一步一步制作yaffs/yaffs2根文件系统(四)---构建etc、dev等剩余目录
  14. Codeforces 235B Let&amp;#39;s Play Osu! 概率dp(水
  15. ioc构架demo
  16. mysql存储过程 基本语法
  17. JSP页面静态包含和动态包含的区别与联系
  18. Cbv源码简单分析图
  19. eclipse 带sts插件
  20. Sybase采用load table加载文本数据中的部分字段数据

热门文章

  1. angular 报错笔记
  2. crontab中使用sudo命令的注意
  3. eclipse01
  4. 读 Real-Time Rendering 收获 - chapter 4. transform
  5. poj1170 - 转换成背包
  6. Vue项目结合vux使用
  7. PHP通过DOM操作XML
  8. sudo不用在输入密码
  9. [NOI2014]动物园(KMP)
  10. Git日常操作指令