Hardwood Species
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 18770   Accepted: 7405

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 

America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the
hardwood species represent 40 percent of the trees in the United States. 



On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber
such as 2x4s and 2x6s, with some limited decorative applications. 



Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483
题意:给一堆单词(有反复),然后按字典序打印出全部单词(无反复) 而且输出每一个单词占总单词数的百分率。
值得注意的是G++提交要用%f 而C++用%lf
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <algorithm>
#include <set>
#include <vector>
#include <string>
#include <map>
#include <queue>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
string x;
long long cnt=0;
map <string,int> m;
while(getline(cin,x)){
cnt++;
m[x]++; }
map <string,int>::iterator it=m.begin();
while(it!=m.end())
{
printf("%s ",it->first.c_str());
printf("%.4lf\n",it->second*100.0/cnt);
++it;
}
return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。

最新文章

  1. 取消ie浏览器edge浏览器输入框右边的叉和眼睛
  2. td:first-child 伪类 匹配第一个 匹配第一个 &lt;td&gt; 元素
  3. 20169212《Linux内核原理与分析》第二周作业
  4. WPF之 DataGrid数据绑定
  5. codevs1227 方格取数2 注意数组啊啊啊啊啊啊啊啊啊啊
  6. 将ubuntu12.04中,gcc4.6/g++4.6版本降低到gcc4.4/g++4.4.
  7. vi/vim使用指北 ---- Learning the vi and Vim Editors 读书 笔记
  8. Nginx+Lua+Redis整合实现高性能API接口 - 网站服务器 - LinuxTone | 运维专家网论坛 - 最棒的Linux运维与开源架构技术交流社区! - Powered by Discuz!
  9. dedecms文章的更新时间问题 每次更改文章时间变成最新的
  10. sql2005数据库置疑修复断电崩溃索引损坏 数据库索引错误修复/数据库表损坏/索引损坏/系统表混乱等问题修复
  11. 【Java】0X003 面向对象
  12. SPOJ Query on a tree V
  13. 配置安装nginx
  14. Android事件机制之二:onTouch详解
  15. mysql 命令汇总
  16. Kubernetes基础:Service
  17. nodejs -- http模块. request() 方法 , get方法.
  18. [NOIP2018]旅行
  19. hadoop MapReduce 入门
  20. Rpgmakermv(30) GameQuest任务插件

热门文章

  1. Cronolog 分割 Tomcat8 Catalina.out日志 (转)
  2. Cocos2d 游戏状态机
  3. C#中防止程序多次运行
  4. (win7/8/10)鼠标右键添加按下SHIFT键时弹出带管理员权限的“在此处打开命令窗口”
  5. 洛谷—— P1018 乘积最大
  6. C#使用wkhtmltopdf.exe,HTML页面转化为PDF文档
  7. Oracle Web链接客户端
  8. Arcgis engine 指定图层对要素进行创建、删除等操作
  9. Launcher Activity在开机时重新启动两次解决的方法
  10. Eclipse RCP 中创建自己定义首选项,并能读取首选项中的值