Binomial Showdown
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18457   Accepted: 5633

Description

In how many ways can you choose k elements out of n elements, not taking order into account? 

Write a program to compute this number.

Input

The input will contain one or more test cases. 

Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n). 

Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 231

Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit. 

Sample Input

4 2
10 5
49 6
0 0

Sample Output

6
252
13983816

题意:求C(n,m);

思路:这个是当中一种办法。就是连乘r个整商:C(n,k)=C(n,k-1)*(n-k+1)/k。时间复杂度O(n);

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
LL work(LL n,LL m)
{
if(m>n/2) m=n-m;
LL a=1,b=1;
for(int i=1;i<=m;i++){
a*=n-i+1;
b*=i;
if(a%b==0){
a/=b;
b=1;
}
}
return a/b;
}
int main()
{
LL n,m;
while(~scanf("%lld %lld",&n,&m)){
if(!n&&!m) break;
printf("%lld\n",work(n,m));
}
return 0;
}

最新文章

  1. 未封装的js放大镜特效
  2. 封装ios静态库碰到的一些问题(二)
  3. C语言 串 顺序结构 实现
  4. wdcp v3 Forbidden :You don&#39;t have permission to access /phpmyadmin on this server
  5. ESB数据发布思路
  6. Python in minute
  7. [Android]Android焦点流程代码分析
  8. IntelliJ IDEA(2017.2)安装和破解(转)
  9. docker挂载点泄露问题
  10. ThunderBird对只有回复地址的邮件过滤
  11. BZOJ3172[Tjoi2013]单词——AC自动机(fail树)
  12. 【JMeter】【接口测试】csv参数化,数据驱动,自动化测试
  13. 牛客网数据库SQL实战(11-15)
  14. vm centos7中用NAT模式配置上网
  15. rsync同步web数据
  16. Java LinkList遍历方式
  17. 【树】Lowest Common Ancestor of a Binary Tree(递归)
  18. eclipse 启动报share library load faild
  19. centos x64 vsftpd 530登陆错误问题
  20. Android App性能測试

热门文章

  1. 老男孩全栈python学习进程表
  2. js 页面刷新 每N秒钟刷新一次页面
  3. css中可继承和不可继承属性
  4. javascript学习笔记 - 引用类型 RegExp
  5. WebApplicationContextUtils源码
  6. NOJ——1274The battle of Red Cliff(并查集按秩合并)
  7. 学习 WebService 第一步:体系结构、三元素SOAP/WSDL/UDDI
  8. 微信小程序中 input组件影响页面样式的问题
  9. 【POJ1276】Cash Machine(多重背包单调队列优化)
  10. php--转码函数