题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.    The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:

2 2

1 1

1 1

-1 -1

10 9

2 3

1 2 3

4 5 6

-1 -2 -3

-4 -5 -60

样例输出:

1

5

简单翻译一下

先输入矩阵行和列的数,再列出2个矩阵的数字,然后矩阵相加,算出行数都是零和列数都是零的总和。

Java

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner; public class Main { public static void main(String[] args) {
List<Integer> mList = new ArrayList<Integer>();
Scanner cin = new Scanner(System.in);
int rows;
while ((rows = cin.nextInt()) != 0) {
int columns;
int totalTmp = 0;
int total = 0;
columns = cin.nextInt();
int[][] arrays1 = new int[rows][columns];
int[][] arrays2 = new int[rows][columns];
for (int i = 0; i < rows; i++) {
for (int j = 0; j < columns; j++) {
arrays1[i][j] = cin.nextInt();
}
}
for (int i = 0; i < rows; i++) {
for (int j = 0; j < columns; j++) {
arrays2[i][j] = cin.nextInt();
totalTmp = totalTmp | (arrays1[i][j] + arrays2[i][j]);
}
if (totalTmp == 0) {
total++;
}
totalTmp = 0;
} for (int colum = 0; colum < columns; colum++) {
for (int row = 0; row < rows; row++) {
totalTmp = totalTmp
| (arrays1[row][colum] + arrays2[row][colum]);
}
if (totalTmp == 0) {
total++;
}
totalTmp = 0;
}
mList.add(total);
}
for (int num : mList) {
System.out.println(num + "");
} }
}

我是天王盖地虎的分割线

最新文章

  1. cloudera learning7:Hadoop资源管理
  2. 数据库中老师学生家长表添加自动同意好友自动(AgreeAddingFriend ),默认为True
  3. Html5 Egret游戏开发 成语大挑战(六)游戏界面构建和设计
  4. python学习笔记整理——元组tuple
  5. [Android Tips] 2. Disable recent apps dialog on long press home button
  6. Big String 块状数组(或者说平方分割)
  7. 转 【O2O案例】汽车后市场垂直化电子商务:平业模式解析
  8. [CFgym]2015-2016 ACM-ICPC Pacific Northwest Regional Contest小结
  9. (转载)无缝滚动图片的js和jquery两种写法
  10. HEX转BIN源码分析(51系列)
  11. android内置存储器memory和第三方外部存储disk管理
  12. Mybatis第一天(其他)
  13. 笔记整理——C语言-http
  14. ASP.NET Zero--14.一个例子(7)商品分类管理-分类搜索及分页
  15. OpenVPN的那些坑
  16. javaWeb之eclipse创建Servlet模板快捷键设置
  17. yum安装k8s集群(kubernetes)
  18. 设计模式のStatePattern(状态模式)----行为模式
  19. IDEA中maven模块变成灰色
  20. 设置 matlab 画图格式

热门文章

  1. Codeforces Round #371 (Div. 1) C. Sonya and Problem Wihtout a Legend 贪心
  2. 【原】用IDEA远程Debug Tomcat服务
  3. OpenVPN推送默认路由表
  4. 解决ubuntu上在androidstudio中启动emulator闪退的问题(2)
  5. CentOS 安装 Jenkins
  6. Java异常(三) 《Java Puzzles》中关于异常的几个谜题
  7. value stored to value2 during its initialization is never read
  8. js alert换行
  9. c++中 extern
  10. OAuth:Access to shared resources via web applications