【BZOJ3011】[Usaco2012 Dec]Running Away From the Barn

Description

It's milking time at Farmer John's farm, but the cows have all run away! Farmer John needs to round them all up, and needs your help in the search. FJ's farm is a series of N (1 <= N <= 200,000) pastures numbered 1...N connected by N - 1 bidirectional paths. The barn is located at pasture 1, and it is possible to reach any pasture from the barn. FJ's cows were in their pastures this morning, but who knows where they ran to by now. FJ does know that the cows only run away from the barn, and they are too lazy to run a distance of more than L. For every pasture, FJ wants to know how many different pastures cows starting in that pasture could have ended up in. Note: 64-bit integers (int64 in Pascal, long long in C/C++ and long in Java) are needed to store the distance values.

给出以1号点为根的一棵有根树,问每个点的子树中与它距离小于l的点有多少个。

Input

* Line 1: 2 integers, N and L (1 <= N <= 200,000, 1 <= L <= 10^18)

* Lines 2..N: The ith line contains two integers p_i and l_i. p_i (1 <= p_i < i) is the first pasture on the shortest path between pasture i and the barn, and l_i (1 <= l_i <= 10^12) is the length of that path.

Output

* Lines 1..N: One number per line, the number on line i is the number pastures that can be reached from pasture i by taking roads that lead strictly farther away from the barn (pasture 1) whose total length does not exceed L.

Sample Input

4 5
1 4
2 3
1 5

Sample Output

3
2
1
1
OUTPUT DETAILS: Cows from pasture 1 can hide at pastures 1, 2, and 4. Cows from pasture 2 can hide at pastures 2 and 3. Pasture 3 and 4 are as far from the barn as possible, and the cows can hide there.

题解:维护一个大根堆,堆中元素的权值就是i到根节点的距离,然后不断弹出堆顶直到堆顶元素的权值小于l就行了

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=200010;
typedef long long ll;
int n,rt[maxn],fa[maxn],siz[maxn],ch[maxn][2],nvl[maxn],head[maxn],next[maxn];
ll dep[maxn],val[maxn],l;
int merge(int x,int y)
{
if(!x) return y;
if(!y) return x;
if(dep[x]<dep[y]) swap(x,y);
ch[x][1]=merge(ch[x][1],y);
if(nvl[ch[x][0]]<nvl[ch[x][1]]) swap(ch[x][0],ch[x][1]);
nvl[x]=nvl[ch[x][1]]+1;
return x;
}
void dfs(int x)
{
siz[x]=1;
for(int i=head[x];i;i=next[i])
{
dep[i]=dep[x]+val[i];
dfs(i);
siz[x]+=siz[i];
rt[x]=merge(rt[x],rt[i]);
while(dep[rt[x]]>l+dep[x])
{
siz[x]--;
rt[x]=merge(ch[rt[x]][0],ch[rt[x]][1]);
}
}
}
int main()
{
scanf("%d%lld",&n,&l);
nvl[0]=-1;
int i;
rt[1]=1;
for(i=2;i<=n;i++)
{
scanf("%d%lld",&fa[i],&val[i]);
next[i]=head[fa[i]],head[fa[i]]=i;
rt[i]=i;
}
dfs(1);
for(i=1;i<=n;i++) printf("%d\n",siz[i]);
return 0;
}
 

最新文章

  1. xmlHttp.readyState的五种状态
  2. javaScript的call关键字
  3. 不一样的Android选择器,简单方便,地址日期时间都好用!
  4. NKUI框架使用
  5. HDU-5536 Chip Factory (字典树)
  6. bzoj1532
  7. css实现带箭头选项卡
  8. java 检查抛出的异常是否是要捕获的检查性异常或运行时异常或错误
  9. [PWA] 9. Service worker registerion &amp;&amp; service work&#39;s props, methods and listeners
  10. 一个int类型究竟占多少个字节
  11. Pro/TOOLKIT入门教程汇总
  12. DedeCMS数据负载性能优化方案简单几招让你提速N倍
  13. 尤克里里 ukulele 单板 非kaka tom uma
  14. iOS原生和H5的相互调用
  15. [物理学与PDEs]第2章习题1 无旋时的 Euler 方程
  16. SpringMVC详细示例实战教程(较全开发教程)
  17. Android so 文件进阶&lt;二&gt; 从dlsym()源码看android 动态链接过程
  18. 开源|如何使用CNN将视频从2D到3D进行自动转换(附源代码)
  19. NBUT 1218 You are my brother 2010辽宁省赛
  20. SqlServer快速获得表总记录数(大数据量)

热门文章

  1. 利用层的table-row、table-cell属性进行页面布局
  2. 关于Cocos2d-x的数据存储
  3. Hibernate注解关系映射
  4. php date strtotime的用法
  5. SQL-字符串连接聚合函数
  6. [转]查看处于被锁状态的表:v$locked_object dba_objects v$session all_objects v$sqlarea v$lock
  7. js中数组作为参数传递的定义
  8. Fast-RCNN
  9. linux中sftp默认登录的端口号是多少? sftp通过指定的端口号连接?sftp默认端口号
  10. mysql数据库binary log中的事件到底是什么?