Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16049    Accepted Submission(s): 5154

Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.

 
Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 
Output
For each case, output the minimum number of broomsticks on a single line.
 
Sample Input
4
10
20
30
04
 
5
2
3
4
3
4
 
Sample Output
1
2
 
Author
PPF@JLU

题目大意:给你n个数,让你判断出现最多的那个数字的次数是多少。由于所给数字有几十位,long long也存不下。所以采用Hash记录每个数,同时记录次数。  由于所给的n个数会有00001这种带前缀0的数据,所以要先处理一下。

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 1e4+200;
struct Chain{
char st[200];
int tm;
Chain *next;
Chain(){
tm = 0;
next = NULL;
}
~Chain(){
}
}Hash_Table[maxn];
int ans;
//BKDR
int Hash(char *s){
unsigned int seed = 131; //13,131,1313 13131 131313
unsigned int v_hash = 0;
while(*s == '0'){
++s;
}
while(*s){
v_hash = v_hash * seed + (*s++);
}
return (v_hash & 0x7fffffff);
}
void Insert(Chain *rt, char *s){
while(*s == '0') s++;
printf("%s\n",s);
while(rt -> next != NULL){
rt = rt->next;
if(strcmp(rt->st,s)==0){
rt->tm++;
ans = max(ans,rt->tm);
return ;
}
}
rt->next = new Chain();
rt = rt->next;
rt->next = NULL;
strcpy(rt->st,s);
rt->tm++;
ans = max(ans,1);
}
void Free(Chain * rt){
if(rt->next != NULL)
Free(rt->next);
{
delete rt;
}
}
int main(){
char s[maxn];
int n, m;
unsigned int H;
while(scanf("%d",&n)!=EOF){
ans = 0;
for(int i = 1; i <= n; ++i){
scanf("%s",s);
H = Hash(s)%2911;
// printf("%u+++++++++++\n",H);
Insert(&Hash_Table[H],s);
}
printf("%d\n",ans);
for(int i = 0; i <= 3200; i++){
if(Hash_Table[i].next == NULL) continue;
Free(Hash_Table[i].next);
Hash_Table[i].next = NULL;
}
}
return 0;
}
/*
5
000
0001
00000
0
1 4
10
0010
00010
11
*/

  

最新文章

  1. out和ref详解
  2. UINavigationBar 和view 重叠覆盖问题
  3. json jsonp的区别
  4. sqllite 默认当前日期写法
  5. js 判断数组包含某值的方法 和 javascript数组扩展indexOf()方法
  6. 19. javacript高级程序设计-E4X
  7. RX编程笔记——JavaScript 获取地理位置
  8. 【转载】db blocks gets &amp; consistent gets
  9. 搜索算法:深度优先搜索(DFS)
  10. Python中的map()函数和reduce()函数的用法
  11. javascript中子类如何继承父类
  12. ECMAscript v.s. Javascript
  13. RBM如何训练?
  14. C# 数组Array
  15. Docker安装Tomcat镜像并部署web项目
  16. XJad反编译工具
  17. react-native 报错
  18. 152 - - G Traffic Light 搜索(The 18th Zhejiang University Programming Contest Sponsored by TuSimple )
  19. java执行shell/cmd命令
  20. Flask实战第38天:前台模型创建

热门文章

  1. 在有主分支和个人分支情况下的TFS使用方法
  2. kali linux之主动信息收集(三层发现,四层发现)
  3. 关于Java中SQL语句的拼接规则
  4. [AGC002D] Stamp Rally 整体二分+并查集
  5. Ubuntu16.04搭建各种开发环境的IDE: QT5 , CodeBlocks ,eclipse-cdt, PyCharm
  6. 关于logging的那些坑
  7. Android蓝牙连接自动测试工具
  8. iOS导入c++语言的静态库之后编译不过,先要检查是否导入了libstdc++
  9. kibana安装汉化包
  10. 搭建git服务器(临时服务器,命令行形式,针对2到5人左右,轻量)