题目链接

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11

8.02

7.43

4.57

5.39

Sample Output

2.00

分析:

根据最长的棍子二分枚举切割长度。

这点很容易想到。

本题麻烦的地方在于小数的二分。

由于精度丢失问题,如果直接使用double进行二分,那么二分确定的最大长度必然是不精确的。

如:只有1根100.0的棍子,分成10段。如果使用double二分,那么就算把精度控制到0.0000001,

最后的答案也就9.9999666。,而不是10.

由于只要求2位小数,则把所有棍子长度*100,变成整数二分即可。

最后答案ans/=100。

代码:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
using namespace std;
int N,K;
double L[10009]; ///判断每小段的长度为x的话,能不能满足分成K段
bool C(double x)
{
int num=0;
for(int i=0; i<N; i++)
{
num+=(int)(L[i]/x);
}
return num>=K;
} void solve()
{
double lb=0,ub=0x3f3f3f3f;
for(int i=0; i<100; i++)///尽可能的将分的范围具体
{
double mid=(lb+ub)/2;
if(C(mid)) lb=mid;
else ub=mid;
}
printf("%.2lf\n",floor(ub*100)/100);
} int main()
{
scanf("%d%d",&N,&K);
for(int i=0; i<N; i++)
scanf("%lf",&L[i]);
solve();
return 0;
}

最新文章

  1. 神经网络与深度学习(3):Backpropagation算法
  2. 在 Azure HDInsight 中安装和使用 Spark
  3. Using Internal EEPROM of PIC Microcontroller
  4. iOS中多线程常用的知识点
  5. prototype 原型
  6. 如何让 height:100%; 起作用
  7. Memcached缓存瓶颈分析
  8. STL--map
  9. fedora22 无法联网的情况下rpm安装gcc5.1
  10. 【bzoj3514】Codechef MARCH14 GERALD07加强版
  11. Future 和 ExecutorCompletionService 对比和使用
  12. JavaScript 中实现继承的方式(列举3种在前一章,我们曾经讲解过创建类的最好方式是用构造函数定义属性,用原型定义方法。)
  13. C# 生成二维码 QRCoder
  14. Windows 2008 打开声音重定向来听到远程主机音频
  15. 理解pytorch中的softmax中的dim参数
  16. 2015-10-29 ado.net 1
  17. HTTP协议基础与web服务的重定向,跳转以及请求转发
  18. OpenCV——反向投影(定位模板图像在输入图像中的位置)
  19. nginx常用超时设置
  20. 一个PHP操作大变量的例子

热门文章

  1. Linux内核策略介绍学习笔记
  2. Windows 7中安装Solr7
  3. 【Linux】- CentOS 7 安装.NET Core 2.1
  4. mysql(三) 慢查询分析(二)
  5. BZOJ 1037 生日聚会(神DP)
  6. 【刷题】BZOJ 4827 [Hnoi2017]礼物
  7. 51NOD 1227:平均最小公倍数——题解
  8. 51nod 1196 字符串的数量(DP+数论?)
  9. 表单验证:nice Validator
  10. Ubuntu Android adb调试无法识别设备 -- List of devices attached ???????????? no permissions