Sekiro: Shadows Die Twice is an action-adventure video game developed by FromSoftware and published by Activision. In the game, the players act as a Sengoku period shinobi known as Wolf as he attempts to take revenge on a samurai clan who attacked him and kidnapped his lord.

As a game directed by Hidetaka Miyazaki, Sekiro (unsurprisingly) features a very harsh death punishment. If the player dies when carrying amount of money, the amount of money will be reduced to , where indicates the smallest integer that .

As a noobie of the game, BaoBao has died times in the game continuously. Given that BaoBao carried amount of money before his first death, and that BaoBao didn’t collect or spend any money during these deaths, what’s the amount of money left after his deaths?

Input

There are multiple test cases. The first line of the input contains an integer (about ), indicating the number of test cases. For each test case:

The first and only line contains two integers and (, ), indicating the initial amount of money BaoBao carries and the number of times BaoBao dies in the game.

Output

For each test case output one line containing one integer, indicating the amount of money left after deaths.

Sample Input

4

10 1

7 1

10 2

7 2

Sample Output

5

4

3

2

Hint

For the third sample test case, when BaoBao dies for the first time, the money he carries will be reduced from 10 to 5; When he dies for the second time, the money he carries will be reduced from 5 to 3.

除了2^31是int最大值,这一点。就是个签到题。大于31直接输出1,恭喜入坑,0的时候是零;

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--){
long long mon,op;
scanf("%lld %lld",&mon,&op);
if(mon==0) cout<<0<<endl;
else if(op>31)cout<<1<<endl;
else
for(int i=0;i<op;i++)
{
if(mon%2==1) mon=mon/2+1;
else mon/=2;
}
cout<<mon<<endl;
}
return 0;
}

最新文章

  1. Android笔记——BaseAdapter的使用
  2. HttpWebRequest出错 服务器提交了协议冲突. Section=ResponseHeader Detail=CR 后面必须是 LF
  3. Nginx限速遇到的问题
  4. 第一个ruby程序
  5. Windows x86/ x64 Ring3层注入Dll总结
  6. php--opp--1.什么是面向对象?
  7. HANDLER命令与实现
  8. *[hackerrank]ACM ICPC Team
  9. css揭秘之linear-gradient
  10. 初探 FFT/DFT
  11. OpenStack_Swift源代码分析——Ring基本原理及一致性Hash算法
  12. IO流的操作规律
  13. angular指令的4种设计模式
  14. SSE 向量乘矩阵
  15. tomcat 发布后中文乱码问题
  16. RAND函数和SRAND函数
  17. redis命令大全参考手册
  18. php版本CKEditor 4和CKFinder安装及配置
  19. cmder切换路径、设置命令别名
  20. [转帖] 固定硬盘接口 U.2和M.2

热门文章

  1. 家庭版记账本app进度之对于按钮的点击事件以及线性布局以及(alertdialog)等相关内容的应用测试
  2. 家庭版记账本app之常用控件的使用方法
  3. MTK Android 设置下添加一级菜单[ZedielPcbTest]
  4. 《民国奇探》的弹幕有点逗比,用 Python 爬下来看看
  5. matplotlib TransformedPath和TransformedPatchPath
  6. 《深入理解 Java 虚拟机》读书笔记:垃圾收集器与内存分配策略
  7. Vm安装虚拟机并使用net模式连接外网
  8. A - Smith Numbers POJ
  9. 数据结构与算法--树(tree)结构
  10. [转载]深度理解Session