A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1
//General Palindromic Number
#include<stdio.h>
#include<vector>
using namespace std;
vector<int>V;
int main(void){
 int n, b;
 while (scanf("%d%d", &n, &b) != EOF){
  V.clear();
  if (n == 0){//如果是0的话,不论什么进制都是回文数字
   puts("Yes");
   printf("0\n");
   continue;
  }
  while (n){//用V来存储b进制下的各个位数
   V.push_back(n % b);
   n /= b;
  }
  bool result  = true;;
  for (int i = 0; i < V.size(); i++){
   if (V[i] != V[V.size() - i - 1]){
    result = false;//一有不等的,就不是回文
    break;
   }
  }
  if (result){
   puts("Yes");
  }
  else puts("No");
  for (int i = V.size() - 1; i >= 0; i --){
   if (i == V.size() - 1)printf("%d", V[i]);
   else printf(" %d", V[i]);
  }
  printf("\n");
 }
 return 0;
}

最新文章

  1. 在xib中用KVC修改控件属性
  2. MAVEN中的插件放在哪个dependcies里面
  3. word2007
  4. C语言编写的随机产生四则运算测试题
  5. 深入浅出ghostbuster剖析NodeJS与PhantomJS的通讯机制
  6. POJ 1364 King
  7. tyvj 1150 绳子围点 Pick定理 防溢出策略
  8. c++ 12
  9. AutoFac使用方法总结
  10. SpringBoot Hello World
  11. MVC生成页码选择器返回HTML代码
  12. SpringBoot系列: Spring MVC视图方法的补充
  13. java类的回顾
  14. cetus系列~安装和基本配置
  15. system
  16. AngularJS中实现显示或隐藏动画效果的3种方式
  17. 1001. [BJOI2006]狼抓兔子【最小割】
  18. 微信小程序的经纬度不想写死,需要转成number类型不能用浮点型
  19. Shell重新学习(忘光了)
  20. [优化]深度学习中的 Normalization 模型

热门文章

  1. 2020/2/13 bluecmsv1.6sp1代码审计
  2. [RoarCTF 2019]Simple Upload
  3. Java集合--Map
  4. 18 11 24 简单的http服务器
  5. centos socket通信时 connect refused 主要是防火墙问题
  6. .equal()和==的区别
  7. java AES加解密
  8. Hough直线and圆环变换(如何检测直线、圆环)
  9. 实现3d效果
  10. Serverless 公司的远程团队沟通策略