Jessica's Reading Problem
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12346   Accepted: 4199

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text
book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains
all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous
part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what
the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

Source


——————————————————————————————————————
题目的意思是给出n页书本的信息,求最小的连续的页数能覆盖全部知识点
思路:先记录有多少个不同知识点,由于数据较大开个map记录知识点处现的次数
尺取法,如果知识点不够,先r++,在判是不是新知识,再更新map,如果够了,先l++,在更新map,在判是不是少了知识点

#include <iostream>
#include <cstring>
#include <cstdio>
#include <map>
#include <queue>
#include <cmath>
#include <algorithm>
#include <set>
using namespace std;
#define LL long long
const int inf=0x3f3f3f3f;
int n,m;
int a[1000005]; int main()
{
while(~scanf("%d",&n))
{
set<int>s;
for(int i=0; i<n; i++)
{
scanf("%d",&a[i]);
s.insert(a[i]);
}
m=s.size();
map<int,int>mp;
int l=0,r=0;
int sum=0;
int ans=inf;
while(1)
{
while(r<n&&sum<m)
{
if(mp[a[r]]==0)
sum++;
mp[a[r++]]++;
}
if(sum<m) break;
ans=min(ans,r-l);
if(mp[a[l]]==1)
sum--;
mp[a[l++]]--;
}
if(ans==inf)
ans=0;
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. iOS路径沙盒文件管理(转载)
  2. 一些常用的方法(1)--去除DataTable中的重复数据
  3. Hibernate控制insert\update语句
  4. flume ng配置拓扑图
  5. 【pyhton】成员资格运算符
  6. BIOS中断大全
  7. 自己动手写CPU之第五阶段(3)——MIPS指令集中的逻辑、移位与空指令
  8. WINFORM中几句程序获取整个屏幕的图片及当前窗口的图片快照
  9. hdu 4467 Graph
  10. .Net 上传图片之前获取图片的宽高
  11. MySQL性能调优——锁定机制与锁优化分析
  12. 通过游戏来学习CSS的Flex布局
  13. 使用SQL语句操作数据
  14. php获取微信的openid
  15. Beta阶段Scrum 冲刺博客合集
  16. 关于 jenkins-cli.jar
  17. Creating objects on stack or heap
  18. LNMP 网站搭建
  19. mpg123解码相关
  20. Android中自定义组合控件

热门文章

  1. Oracle_高级功能(5) 用户、角色、权限
  2. 自定义标签tld的使用
  3. C++中的getline()
  4. andorid 计算器
  5. 八皇后问题(dfs)
  6. LibreOJ #6002. 「网络流 24 题」最小路径覆盖
  7. [Selenium Grid] 搭建Hub和Node环境
  8. Spring 注解(一)Spring 注解编程模型
  9. rap2与postman自动化测试
  10. 秒懂 this