Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定。现在我们封装一个“Point类”来实现平面上的点的操作。

根据“append.cc”,完成Point类的构造方法和show()方法,输出各Point对象的构造和析构次序。

接口描述:
Point::show()方法:按输出格式输出Point对象。

Input

输入多行,每行为一组坐标“x,y”,表示点的x坐标和y坐标,x和y的值都在double数据范围内。

Output

输出每个Point对象的构造和析构行为。对每个Point对象,调用show()方法输出其值:X坐标在前,Y坐标在后,Y坐标前面多输出一个空格。每个坐标的输出精度为最长16位。输出格式见sample。

C语言的输入输出被禁用。

Sample Input

1,2
3,3
2,1

Sample Output

Point : (0, 0) is created.
Point : (1, 2) is created.
Point : (1, 2)
Point : (1, 2) is erased.
Point : (3, 3) is created.
Point : (3, 3)
Point : (3, 3) is erased.
Point : (2, 1) is created.
Point : (2, 1)
Point : (2, 1) is erased.
Point : (0, 0) is copied.
Point : (1, 1) is created.
Point : (0, 0)
Point : (1, 1)
Point : (0, 0)
Point : (1, 1) is erased.
Point : (0, 0) is erased.
Point : (0, 0) is erased.

HINT

思考构造函数、拷贝构造函数、析构函数的调用时机。

Append Code

int main()
{
    char c;
    double a, b;
    Point q;
    while(std::cin>>a>>c>>b)
    {
        Point p(a, b);
        p.show();
    }
    Point q1(q), q2(1);
    q1.show();
    q2.show();
    q.show();
}
 
代码
#include <iostream>
#include <iomanip>

using namespace std;

class Point
{
    double x;
    double y;
public:
    Point():x(0),y(0)
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is created."<<endl;
    }
    Point(double a,double b):x(a),y(b)
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is created."<<endl;
    }
    Point(double a):x(a),y(1)
    {
        cout <<setprecision(16)<<"Point : ("<<x<<", "<<y<<")"<<" is created."<<endl;
    }
    Point(const Point& p)
    {
        x=p.x; y=p.y;
        cout <<setprecision(16)<<"Point : ("<<p.x<<", "<<p.y<<")"<<" is copied."<<endl;
    }
    ~Point()
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<") is erased."<<endl;
    }
    void show()
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")"<<endl;
    }
};

int main()
{
    char c;
    double a, b;
    Point q;
    while(std::cin>>a>>c>>b)
    {
        Point p(a, b);
        p.show();
    }
    Point q1(q), q2(1);
    q1.show();
    q2.show();
    q.show();
}

最新文章

  1. [转]Objective-c中@interface、@implementation、@protocal
  2. nodejs--模块
  3. Math-基本功能
  4. Linux开启关闭redis
  5. C#操作FTP, FTPHelper和SFTPHelper
  6. 理解C++中函数的返回
  7. 对程序员的不尊重是中国it产业的悲哀。
  8. Android---OpenGL ES之添加动作
  9. Java读书笔记1
  10. VC++实现小托盘的处理
  11. Java基础知识二次学习--第七章 容器
  12. 【AHOI2005】病毒检测
  13. EF架构~mysql中时间戳字段被认为是主键自增
  14. Asp.net Core 使用Jenkins + Dockor 实现持续集成、自动化部署(二):部署
  15. zookeeper在windows及linux(含多节点)环境下安装及其命令使用
  16. restTemplate 发送http post请求带有文件流、参数
  17. Helm简介
  18. spring boot配置druid数据源和监控配置
  19. [android] WebView自定义浏览器
  20. 洛谷P1803

热门文章

  1. JS实现悬浮导航的制作(附源码)--web前端
  2. org.springframework.web.multipart.MultipartException: Failed to parse multipart servlet request; nested exception is java.io.IOException: The temporary upload location [/tmp/tomcat.1428942566812653608
  3. p1473 Zero Sum
  4. C#方式操作Cookie
  5. Confluence 6 指派和撤销空间权限
  6. github第一步之初始化操作
  7. web功能模块测试用例(模板)
  8. input type=&quot;number&quot; 时 maxlength不起作用
  9. nyoj-1015-二分图判定
  10. 数据结构与算法之PHP查找算法(哈希查找)