<span style="font-size: 18pt; font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">K - </span><span style="color: blue; font-size: 18pt; font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">Quadtrees</span>

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld
& %llu

Appoint description: 
System Crawler  (2014-01-02)

Description

 Quadtrees 

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants,
etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.

Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors.
As a result, the quadtree need not be of uniform depth.

A modern computer artist works with black-and-white images of  units, for a total
of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.

This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels
in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are
black in the image, which is the result of adding the two images together.

In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.

Input Specification

The first line of input specifies the number of test cases (N) your program has to process.

The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter 'p' indicates a parent node, the letter 'f'
(full) a black quadrant and the letter 'e' (empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).

Output Specification

For each test case, print on one line the text 'There are X black pixels.', where X is the number of black pixels in the resulting image.

Example Input

3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

Example Output

There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.

题意:有一个用四叉树表示的图,该图用P,E,F来表示,P表示父节点,F表示黑色,E表示白色,整个图的大小为1024。每个子图都能分成四个部分(当颜色不同的时候才须要划分),如今要把两个图合并成一个图,求合并后图有多少黑色像素。

#include<stdio.h>
#include<cstring>
#include<algorithm>
int T;
char s1[2049],s2[2049];
struct quadtree
{
int num;
quadtree *next[4];
quadtree()
{
num=0;
for(int i=0; i<4; i++)next[i]=0;
}
};
quadtree *build(char *s)///建树
{
quadtree *now=new quadtree;
int len=strlen(s);
if(s[0]!='p')
{
now->num=1;
if(s[0]!='f')
{
delete now;
now=NULL;
}
return now;
}
int up=4;///子树数目
int d=1;
for(int i=1; d<=up&&i<len; i++)
{
if(s[i]=='p')
{
now->next[d-1]=build(s+i);
int dx=0,dy=4;
while(dx<dy)
{
dx++;
if(s[i+dx]=='p')dy+=4;
}
i+=dx;///i变到下一颗子树的起始位置
}
else
{
now->next[d-1]=build(s+i);
}
d++;
}
return now;
}
quadtree *merge_(quadtree *p,quadtree *q)///合并
{
if(p||q)
{
quadtree *root=new quadtree;
if(p&&q)for(int i=0; i<4; i++)
{
if(p->num||q->num)
{
root->num=1; ///子树已经全为黑色,不须要继续递归
continue;
}
root->next[i]=merge_(p->next[i],q->next[i]);
}
else if(p==NULL&&q)for(int i=0; i<4; i++)
{
if(q->num)
{
root->num=1;; ///子树已经全为黑色,不须要继续递归
continue;
}
root->next[i]=merge_(NULL,q->next[i]);
}
else for(int i=0; i<4; i++)
{
if(p->num)
{
root->num=1;; ///子树已经全为黑色,不须要继续递归
continue;
}
root->next[i]=merge_(p->next[i],NULL);
}
return root;
}
return NULL;
}
int dfs(quadtree *p,int num)
{
if(p==NULL)return 0;
int sum=0;
if(p->num)sum+=num;
for(int i=0; i<4; i++)
{
sum+=dfs(p->next[i],num/4);
}
return sum;
}
int main()
{
//freopen("in.txt","r",stdin);
quadtree *root1,*root2,*root;
scanf("%d",&T);
while(T--)
{
scanf("%s%s",s1,s2);
root=root1=root2=NULL;
root1=build(s1);
root2=build(s2);
root=merge_(root1,root2);
printf("There are %d black pixels.\n",dfs(root,1024));
}
return 0;
}

最新文章

  1. Eclipse开发工具组合键介绍
  2. iPhone 6/plus iOS Safari fieldset border 边框消失
  3. Microsoft Dynamics AX 2012: How to get Company,Customer and Vendor address in AX 2012
  4. EPUBBuilder编辑器新版
  5. HTTP协议学习---(五)压缩
  6. Nginx反向代理多虚拟主机代理
  7. Lua 笔记
  8. angularjs开发常见问题-1(持续更新中...)
  9. Javascript知识三
  10. NoSQL发展简史、粗略分类及选择
  11. oracle数据库如何打印九九乘法表
  12. opacity的背景透明&amp;background中rgba的背景色透明
  13. 使用kbmmw 生成客户端delphi函数原型
  14. ubuntu install pip
  15. oracle级联删除
  16. rman list命令
  17. Android 常见SD卡操作
  18. HLS图像处理系列——肤色检測
  19. JavaScript作用域原理——预编译
  20. [NOI2015]软件包管理器(树链剖分,线段树)

热门文章

  1. 十分钟了解MVVMLight
  2. 关于BootStrap下图标的显示问题
  3. bzoj 1070: [SCOI2007]修车 费用流
  4. apache asp.net
  5. EasyUI 树形菜单tree 定义图标
  6. JAVA 抛出与声明异常
  7. linux svn服务器搭建、客户端操作、备份与恢复
  8. Webx之表单验证
  9. Win7,8的上帝模式文件夹 GodMode.{ED7BA470-8E54-465E-825C-99712043E01C}
  10. 笔记本CPU的型号和类型的区分方法