1.  Telnet

Switch Config:

Switch>en

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#enable secret zhang

Switch(config)#line console 0

Switch(config-line)#password 123

Switch(config-line)#login

Switch(config-line)#exit

Switch(config)#line vty 0 15

Switch(config-line)#password hello

Switch(config-line)#login

Switch(config-line)#exit

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.1.1 255.255.255.0

Switch(config-if)#no shutdown

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan1, changed state to up

Switch(config-if)#exit

Switch(config)#exit

Switch#

Switch#show running-config

Building configuration...

Current configuration : 1152 bytes

!

hostname Switch

!

enable secret 5 $1$mERr$Ihkqz6Aphv2yflqGpdU2m0

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

!

line con 0

password 123

login

!

line vty 0 4

password hello

login

line vty 5 15

password hello

login

!

!

end

Switch#

PC1 Telnet Test:

2.  SSH

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#line vty 0 15

Switch(config-line)#login local

Switch(config-line)#exit

Switch(config)#username user1 password 123

Switch(config)#username user2 password 123

Switch(config)#ip domain-name example.com

Switch(config)#crypto key generate rsa

% Please define a hostname other than Switch.

Switch(config)#hostname zhang

zhang(config)#crypto key generate rsa

The name for the keys will be: zhang.example.com

Choose the size of the key modulus in the range of 360 to 2048 for your

General Purpose Keys. Choosing a key modulus greater than 512 may take

a few minutes.

How many bits in the modulus [512]: 1024

% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

zhang(config)#ip ssh version 2

*?? 1 0:30:20.486:  %SSH-5-ENABLED: SSH 1.99 has been enabled

zhang(config)#

zhang(config)#

3.  Encrypting Password

conf t

service password-encryption

4.  Support Telnet SSH on vty line

transport input all or transport input telnet ssh : support both

transport input none: Support neither

transport input telnet: Support only Telnet

transport input ssh: Support only SSH

最新文章

  1. 教你分分钟学会用python爬虫框架Scrapy爬取心目中的女神
  2. 点餐系统3个sprint的团队贡献分
  3. 解决AndroidStudio中文乱码问题
  4. window SVN设置忽略文件列表
  5. 【python】入门学习(二)
  6. node
  7. Shadowsock搭建
  8. Python 练习 21
  9. 5个难以置信的VS 2015预览版新特性
  10. QVariant类学习(非常强大的类型,甚至能处理QMap<QString ,QVariant>)
  11. ASP 调用dll(VB)及封装dll实例
  12. Android Studio中关于Project与Module
  13. 【.NET-EF】Entity Framework学习笔记2 - 增删改(没查询)
  14. js中的clientWidth offsetWidth scrollWidth等的含义
  15. 绝世好题bzoj4300
  16. 第8章 CentOS包管理详解
  17. Maven学习总结(11)——Maven Tomcat7自动部署
  18. bzoj2330
  19. eclipse git 忽略文件
  20. PAT 甲级 1117 Eddington Number

热门文章

  1. Android Activity的启动过程
  2. .NET中的Queue和Stack
  3. CI框架程序--本地调试之后部署新浪SAE
  4. java中serializable
  5. C语言知识总结(5)
  6. 点击文字label同时选中checkbox radio
  7. PC上面的蓝牙的通信(C#)
  8. C++调用GDAL库读取并输出tif文件,并计算斑块面积输出景观指数:CSD
  9. 模板template
  10. Makefile中=、:=、+=、?=的区别