Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 23093   Accepted: 11379

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 



You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The
end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

解题思路:

并查集的简单应用。

最后分成了多少集合就是结果。

代码:

#include <iostream>
#include <stdio.h>
using namespace std;
const int maxn=50010;
int parent[maxn];
int n,m; void init(int n)
{
for(int i=1;i<=n;i++)
parent[i]=i;
} int find(int x)
{
return parent[x]==x?x:find(parent[x]);
} void unite(int x,int y)
{
x=find(x);
y=find(y);
if(x==y)
return ;
else
parent[x]=y;
} int main()
{
int c=1;
while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
{
int x,y;
init(n);
for(int i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
unite(x,y);
}
int cnt=0;
for(int i=1;i<=n;i++)
if(parent[i]==i)
cnt++;
cout<<"Case "<<c++<<": "<<cnt<<endl;
}
return 0;
}

最新文章

  1. The certificate used to sign ***has either expired or has been revoked. An updated certificate is required to sign and install the application
  2. 博客开篇:随笔《从windows到linux的转变》。
  3. 视图(View) &ndash; ASP.NET MVC 4 系列
  4. sql复制数据表和表结构
  5. c++ encode decode
  6. java计时代码
  7. python 执行shell命令
  8. C#操作Word文档(加密、解密、对应书签插入分页符)
  9. mysql之inner join 和left join/right join
  10. webstorm安装与本地激活
  11. mysql zip 文件安装
  12. API创建/更新员工薪水
  13. EBS开发技术之Patch安装
  14. 只需两步!Eclipse+Maven快速构建第一个Spring Boot项目
  15. vue项目上传Github预览
  16. 经典JS的HTML转义与反转义字符
  17. P4178 Tree
  18. python,练习乌龟吃鱼
  19. Oracle分析函数简析
  20. LeetCode--401--二进制手表

热门文章

  1. BNUOJ 52516 Just A String
  2. 洛谷P2147 [SDOI2008] 洞穴勘探 [LCT]
  3. 关于如何在 Unity 的 UI 菜单中默认创建出的控件 Raycast Target 属性默认为 false
  4. 【欧拉回路】UVA - 10054 The Necklace
  5. RabbitMQ (十六) 消息队列的应用场景 (转)
  6. 【Python】闭包Closure
  7. 【尺取法好题】POJ2566-Bound Found
  8. 53.FIB词链
  9. bzoj 3969: [WF2013]Low Power 二分
  10. 在pcDuino上使用蓝牙耳机玩转音乐