Dungeon Master
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13923   Accepted: 5424

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 

L is the number of levels making up the dungeon. 

R and C are the number of rows and columns making up the plan of each level. 

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 

If it is not possible to escape, print the line

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.# #####
#####
##.##
##... #####
#####
#.###
####E 1 3 3
S##
#E#
### 0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

这道题最坑人的地方在于poj上将他分类为dfs,结果一写就超时,其实写最短路一般肯定是bfs,哎,经验还是太浅了。
这道题还有一个值得注意的地方就是这是个3维的迷宫,只需要加上上下两个方向就行了,其他的就是简单的bfs。
这道题wa了半天,居然是我忘记把文件输入输出那句话给删了,尼玛!
下面是代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#define pan(a,b,c) (a<=b&&b<=c)
using namespace std; int dir[6][3]={{0,0,-1},{0,0,1},{-1,0,0},{1,0,0},{0,-1,0},{0,1,0}};
char map[35][35][35];
int vis[35][35][35];
int t,m,n,flag;
struct node{
int x,y,z;
int num;
}que[30010]; void bfs(int sx,int sy,int sz){
int head=0;
int tail=1;
que[0].x=sx;
que[0].y=sy;
que[0].z=sz;
que[0].num=0;
vis[sx][sy][sz]=1;
flag=0;
int xx,yy,zz;
while(head<tail){
for(int i=0;i<6;i++){
xx=que[head].x+dir[i][0];
yy=que[head].y+dir[i][1];
zz=que[head].z+dir[i][2];
if(map[xx][yy][zz]=='E'){//搜到终点
printf("Escaped in %d minute(s).\n",que[head].num+1);
flag=1;
break;
}
if(pan(1,xx,t)&&pan(1,yy,m)&&pan(1,zz,n)&&vis[xx][yy][zz]==0&&map[xx][yy][zz]=='.'){//如果在迷宫内,并且未走过
que[tail].x=xx;
que[tail].y=yy;
que[tail].z=zz;
que[tail].num=que[head].num+1;
vis[xx][yy][zz]=1;
tail++;
}
}
if(flag)
break;
head++;//flag不为1,那就要在继续往后走
}
if(!flag)
cout<<"Trapped!"<<endl;
} int main(){
//freopen("input.txt","r",stdin);
//freopen("output.txt","w",stdout);
int i,j,k;
int sx,sy,sz;
while(scanf("%d%d%d",&t,&m,&n)!=EOF){
if(t==0&&m==0&&n==0) break;
for(i=1;i<=t;i++)
for(j=1;j<=m;j++)
for(k=1;k<=n;k++){
cin>>map[i][j][k];
if(map[i][j][k]=='S'){//找到起点
sx=i;
sy=j;
sz=k;
}
}
memset(vis,0,sizeof(vis));
bfs(sx,sy,sz);
}
return 0;
}
												

最新文章

  1. nginx配置多个虚拟主机vhost
  2. 第三章 DOM
  3. js json 对象相互转换
  4. hive 的mysql配置
  5. vijosP1014 旅行商简化版
  6. java 加载图片的几种方式
  7. Android利用tcpdump和wireshark抓取网络数据包
  8. Android MediaPlayer Error -1004
  9. avalonjs1.5 入门教程
  10. java多线程有几种实现方法,都是什么?同步有几种实现方法,都是什么?
  11. php Socket通信
  12. SAP HUM 拆包之后的HU号码依旧存在
  13. 修改MAC地址的方法 破解MAC地址绑定(抄)
  14. Fedora 19安装mysql
  15. shell 检测安装包
  16. 阿里云小规模web集群分享(电商)
  17. linux查看当前文件夹的大小
  18. MongoDB DBA 实践5-----复制集集群的数据同步和故障转移
  19. centos 安装 redis
  20. (转) 问题解决:Apache: You don&#39;t have permission to access / on this server

热门文章

  1. 基于Android Studio搭建hello world工程
  2. 微软嵌入式WEC2013产品研讨会(深圳站---2013.10.16)
  3. sublime打开文件时自动生成并打开.dump文件
  4. hdu4745Two Rabbits(dp)
  5. 彻底搞清js中闭包(Closure)的概念
  6. mac系统 虚拟机安装教程
  7. Oracle函数:求两个数的最小公倍数
  8. 五指cms筛选功能的实现:
  9. bzoj 2301 [HAOI2011]Problem b(莫比乌斯反演)
  10. uvalive 3218 Find the Border