Pearls

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 12
Problem Description
In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the prices remain the same. For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.
Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.
 
Input
The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.
 
Output
For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.
 
Sample Input
2
2
100 1
100 2
3
1 10
1 11
100 12
 
Sample Output
330
1344
 
 
 
状态转移方程 dp[i]=min(dp[i],dp[j]+(sum_num(j+1...i)+10)*va[i])
 
 
 
 
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 999999999
struct pearl
{
int num,va;
}p[101]; int cmp(const pearl &p1,const pearl &p2)
{
if(p1.va<p2.va)
return 1;
else
return 0;
} int main()
{
int n;
cin>>n;
while(n--)
{
int i,j,k,c,dp[101];
cin>>c;
for(i=1;i<=c;i++)
{
cin>>p[i].num>>p[i].va;
dp[i]=INF;
}
dp[0]=0;
sort(p,p+c,cmp);
for(i=1;i<=c;i++)
{
for(j=0;j<=i;j++)
{
int total=0;
for(k=j+1;k<=i;k++)
total+=p[k].num;
if(dp[j]+(total+10)*p[i].va<dp[i])
dp[i]=dp[j]+(total+10)*p[i].va;
}
}
/*for(i=0;i<=c;i++)
cout<<dp[i]<<endl;*/
cout<<dp[c]<<endl;
}
}
 
 
 
 

最新文章

  1. C#解析HTML
  2. UEFI Bootable USB Flash Drive - Create in Windows(WIN7 WIN8)
  3. Effective Java
  4. LinkedList源码分析
  5. java 生成随机数
  6. JQuery基础汇总
  7. cocos2d-x RenderTexture
  8. shell实现查询oracle数据库表,并写到本地txt文件
  9. android 嵌套 apk 从一个apk启动另外一个apk
  10. 使用高性能xml序列化框架jibx作为spring mvc的xml view
  11. [置顶] android关机闹钟设计思路
  12. zf-关于更改账号密码的问题
  13. Linux安装SVN服务器
  14. 取得 iframe 容器的 URL
  15. 一些 NSArray 的基本操作代码例子
  16. 十三篇系列:king转折点,wooga瓶颈,supercell营收结构
  17. 关于 Keil uVision2 中文注释会显示不完整,字体不正常的问题
  18. 【C++】拷贝构造函数和赋值符函数
  19. centos无法通过ssh连接的解决
  20. C#.NET常见问题(FAQ)-SplitPanel如何设置上下和左右

热门文章

  1. 小而美的js程序
  2. 6/3 Sprint2 看板和燃尽图
  3. Github/Eclipse管理Maven项目
  4. python与unicode
  5. 开源牛人 zcbenz
  6. Spring学习(二)——Spring中的AOP的初步理解[转]
  7. HTTP 错误 500.22 - Internal Server Error 检测到在集成的托管管道模式下不适用的 ASP.NET 设置
  8. linux 磁盘管理以及维护
  9. Writing an Hadoop MapReduce Program in Python
  10. php file_get_contents curl发送cookie,使用代理