Carries

frog has n
integers a1,a2,…,an,
and she wants to add them pairwise.

Unfortunately, frog is somehow afraid of carries (进位). She defines hardness
h(x,y)
for adding x
and y
the number of carries involved in the calculation. For example,
h(1,9)=1,h(1,99)=2.

Find the total hardness adding n
integers pairwise. In another word, find

∑1≤i<j≤nh(ai,aj)

.

Input

The input consists of multiple tests. For each test:

The first line contains 1
integer n
(2≤n≤105).
The second line contains n
integers a1,a2,…,an.
(0≤ai≤109).

Output

For each test, write 1
integer which denotes the total hardness.

Sample Input

    2
    5 5
    10
    0 1 2 3 4 5 6 7 8 9

Sample Output

    1
    20
原题链接: http://acm.scu.edu.cn/soj/problem.action?id=4437

题意:给出几组测试数据,要求分别输出每组数的所有元素相加会发生多少次进位,输出进位数。
方法:分别求每位上的的进位数,直接快速排序,然后两个指针扫描。
代码如下:

#include<iostream>
#include<algorithm>
#include<cmath>
#define maxn 100005
using namespace std;
long long int mergesort(int a[],int begin,int end)
 {
     int b[maxn];
     long long num;
     long long count=0;
     int n=end+1,p;
     int q,r;
     for(int k=1;;k++)
     {
         p=0,q=0,r=end;
         num=pow(10,k);
         for(int i=0;i<n;i++)
         {
             b[i]=a[i]%num;
             if(b[i]!=a[i])
             {
                 p=1;
             }
         }
         sort(b,b+n);
         while(r!=q)
         {
             if(b[q]+b[r]>=num)
             {
                 count+=r-q;
                 r--;
             }
             else 
             {
                 q++;
             }
         }
         if(p==0)
         break;
     }
     return count;
 }
int main(void)
 {
     int n,a[maxn];
     while(cin>>n)
     {
         for(int i=0;i<n;i++)
         cin>>a[i];
         cout<<mergesort(a,0,n-1)<<endl;
     }
     return 0;
 }

最新文章

  1. Java——jar命令
  2. Cach&#233;数据库学习笔记(1)
  3. 【转】深入理解TextView实现Rich Text--在同一个TextView设置不同字体风格
  4. Javascript原理
  5. shell判断条件是否存在
  6. andriod 开发记录apidemos 错误解决
  7. CentOS下php使用127.0.0.1不能连接mysql的解决方法
  8. Palindrome(POJ 1159 DP)
  9. C# Web对文件的管理
  10. openstack nova修改实例路径,虚拟磁盘路径
  11. 网络爬虫之定向爬虫:爬取当当网2015年图书销售排行榜信息(Crawler)
  12. webService常见问题
  13. python web环境相关
  14. 201521123111《Java程序设计》第3周学习总结
  15. ubuntu安装qq教程
  16. Spring Boot报错 MultipartException The temporary upload...
  17. 小程序之带参数跳转到tab页
  18. iOS UI-手势(Gesture)
  19. HawkHost老鹰主机更换主域名方法
  20. 在 Ruby 中执行 Shell 命令的 6 种方法

热门文章

  1. linux_文件类型
  2. junit3.8的使用
  3. POI--HSSFCell类
  4. cache.config文件配置模板
  5. Java设计模式之策略模式与状态模式
  6. Animations and transitions
  7. python os模块实用函数
  8. NIO基础篇(二)
  9. 洛谷 [P3258] 松鼠的新家
  10. 洛谷 [P3254] 圆桌问题