题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3

CS301111 15:30:28 17:00:10

SC3021234 08:00:00 11:25:25

CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目解析

早上来的最早的人要开门,晚上离开的最晚的人要锁门。

给出M个人的编号 到达时间 离开时间

输出 开门的那个人的编号 锁门的那个人的编号

这题真没啥意思,不就是一个排序或者说比大小

千万不要去创建结构体,真没必要,我们只需要编号,所以直接用两个变量保存负责开门的编号,负责关门的编号,在读入这些人信息的时候直接做比较,根据到达时间判断改变这个两个变量就可以了。

至于怎么保存“时间”以及比较,你可以把它转为以00:00:00开始的秒数,但我比较懒,直接用string类对象比较,> < 就可以搞定,只是比较字符串可能比比较整数速度慢,但是影响不大。

代码

#include <iostream>
#include <string>
using namespace std; int main() { // m个员工
int m;
cin >> m;
// 开锁的员工,上锁的员工
string unlock_no, lock_no;
// 初始化开锁时间,上锁时间
string unlock_time = "23:59:59", lock_time = "00:00:00";
// 当前员工编号,到达时间,离开时间
string emp_no, sign_in_time, sign_out_time;
for (int i = 0; i < m; ++i) {
cin >> emp_no >> sign_in_time >> sign_out_time;
// 最早来的那个人开锁,通过string类对象比较方法
if (sign_in_time < unlock_time) {
unlock_time = sign_in_time;
unlock_no = emp_no;
}
// 最晚走的那个人锁门
if (sign_out_time > lock_time) {
lock_time = sign_out_time;
lock_no = emp_no;
}
}
// 开锁的 锁门的
cout << unlock_no << " " << lock_no;
return 0;
} // 将时间转为秒进行比较
// int main() {
// int n, minn = INT_MAX, maxn = INT_MIN;
// scanf("%d", &n);
// string unlocked, locked;
// for(int i = 0; i < n; i++) {
// string t;
// cin >> t;
// int h1, m1, s1, h2, m2, s2;
// scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
// int tempIn = h1 * 3600 + m1 * 60 + s1;
// int tempOut = h2 * 3600 + m2 * 60 + s2;
// if (tempIn < minn) {
// minn = tempIn;
// unlocked = t;
// }
// if (tempOut > maxn) {
// maxn = tempOut;
// locked = t;
// }
// }
// cout << unlocked << " " << locked;
// return 0;
// }

最新文章

  1. PHP面试总结
  2. hdu 3473 Minimum Sum
  3. xcode如何将系统语言改为中文,可修改拍照界面retake和use按钮
  4. 常用SQL语句(工作)
  5. android 打包流程
  6. swift someObject == nil 如何实现
  7. UVa 11014 (莫比乌斯反演) Make a Crystal
  8. c#中怎么删除一个非空目录
  9. 2014年的Google I/O app设计中的材料设计-渣渣的翻译
  10. R语言 系统聚类分析1
  11. 1040. Longest Symmetric String (25)
  12. c++中一个类所占用的空间
  13. SPI模式下MCU对SD卡的控制及操作命令(转)
  14. C# 引用参数
  15. C++ qsort
  16. 【升鲜宝】生鲜配送管理系统_升鲜宝 V2.0 按客户商品分类分开打印配送与按客户商品分类导出相关订单商品相关说明(一)
  17. iso data 聚类算法
  18. excel 中批量生成mysql的脚本
  19. arcpy 零碎知识
  20. markdown 换行

热门文章

  1. mybatis源码学习:一级缓存和二级缓存分析
  2. Centos8安装Docker提示:package docker-ce-3:19.03.8-3.el7.x86_64 requires containerd.io &gt;= 1.2.2-3, but none of the providers can be installed
  3. 一、Go语言由来与关键时间线
  4. PHP Ajax 跨域问题解决方案
  5. Service Location Protocol SLP
  6. Makefile: missing separator(did you mean TAB instead of 8 spaces?). Stop.
  7. 利用jsDeliver+github实现免费CDN
  8. 从Spring迁移到Spring Boot
  9. Ubuntu 之 win10更新ubuntu启动项消失
  10. Font-Awesome使用教程