Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43847    Accepted Submission(s): 16487

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

水题一道,1、5、0、6结尾的次方均为本身,其余可以看作4次一循环。

#include<iostream>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
ll power(const ll a,const ll n)
{
ll sum=1;
for (int i=1; i<=n; i++)
{
sum=sum*a;
}
return sum;
}
int main(void)
{
ll n,t,ans;
int tt;
cin>>tt;
while (tt--)
{
cin>>n;
t=n%10;
if(t==1||t==5||t==0||t==6)
{
cout<<t<<endl;
continue;
}
else
{
ans=power(t,n%4+4)%10;
cout<<ans<<endl;
continue;
}
}
return 0;
}

最新文章

  1. 快手4.0 (KSCAD)
  2. unity 实现简单的分离
  3. Linux内核分析第三周学习总结:构造一个简单的Linux系统MenuOS
  4. PS网页设计教程XXVII——设计一个大胆和充满活力的作品集
  5. 树莓派 Linux 剪贴板
  6. for xml path以及sql合并查询
  7. Centos6.3 jekyll环境安装
  8. Struts-2.3.24.1官方例子-struts2-blank
  9. paip.超实用 360浏览器最近频繁奔溃解决流程.
  10. Linux用户行为日志审计
  11. ASP.NET(C#) GridView (编辑、删除、更新、取消)
  12. Android中强大的Matrix操作
  13. java bootstrap分页
  14. HDU 3046Pleasant sheep and big big wolf(切最小网络流)
  15. 下载安装ActiveMQ(消息队列)
  16. LAMP第三部分php,mysql配置
  17. 解决CUICatalog: Invalid asset name supplied问题
  18. POJ 3829 Seat taking up is tough(——只是题目很长的模拟)
  19. 沃尔夫勒姆自动机时空图输出 C语言实现
  20. 关于ava容器、队列,知识点总结

热门文章

  1. C#之winform实现文件拖拽功能【转】
  2. java基础—基础语法1
  3. Eclipse:Win10中设置Courier New字体
  4. lua调用java过程
  5. 配置centos7解决 docker Failed to get D-Bus connection 报错
  6. LeetCode之Weekly Contest 91
  7. python入门:简单模拟登陆时UTF-8转换成GBK编码
  8. Thinkphp5 获取执行的sql语句
  9. leetcode-22-string
  10. 水题:51Nod1095-Anigram单词