Intelligence System

        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
              Total Submission(s): 2909    Accepted Submission(s): 1259

Problem Description
After a day, ALPCs finally complete their ultimate intelligence system, the purpose of it is of course for ACM ... ... 
Now, kzc_tc, the head of the Intelligence Department (his code is once 48, but now 0), is sudden obtaining important information from one Intelligence personnel. That relates to the strategic direction and future development of the situation of ALPC. So it need for emergency notification to all Intelligence personnel, he decides to use the intelligence system (kzc_tc inform one, and the one inform other one or more, and so on. Finally the information is known to all).
We know this is a dangerous work. Each transmission of the information can only be made through a fixed approach, from a fixed person to another fixed, and cannot be exchanged, but between two persons may have more than one way for transferring. Each act of the transmission cost Ci (1 <= Ci <= 100000), the total cost of the transmission if inform some ones in our ALPC intelligence agency is their costs sum. 
Something good, if two people can inform each other, directly or indirectly through someone else, then they belong to the same branch (kzc_tc is in one branch, too!). This case, it’s very easy to inform each other, so that the cost between persons in the same branch will be ignored. The number of branch in intelligence agency is no more than one hundred.
As a result of the current tensions of ALPC’s funds, kzc_tc now has all relationships in his Intelligence system, and he want to write a program to achieve the minimum cost to ensure that everyone knows this intelligence.
It's really annoying!
 
Input
There are several test cases. 
In each case, the first line is an Integer N (0< N <= 50000), the number of the intelligence personnel including kzc_tc. Their code is numbered from 0 to N-1. And then M (0<= M <= 100000), the number of the transmission approach.
The next M lines, each line contains three integers, X, Y and C means person X transfer information to person Y cost C. 
 
Output
The minimum total cost for inform everyone.
Believe kzc_tc’s working! There always is a way for him to communicate with all other intelligence personnel.
 
Sample Input
3 3
0 1 100
1 2 50
0 2 100
3 3
0 1 100
1 2 50
2 1 100
2 2
0 1 50
0 1 100
 
Sample Output
150
100
50
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  3069 3077 3070 3071 3073 
 
思路:
 先tarjan缩点,然后贪心加边将这几个连通块连接起来
代码:
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 300010
using namespace std;
bool vis[N];
int n,m,x,y,z,s,tot,num,sum,ans,top,tim;
int fa[N],low[N],dfn[N],stack[N],head[N],belong[N];
int read()
{
    ,f=; char ch=getchar();
    ; ch=getchar();}
    +ch-'; ch=getchar();}
    return x*f;
}
struct Edge
{
    int to,dis,next;
}edge[N];
struct Edde
{
    int x,y,z;
}edde[N];
int add(int x,int y,int z)
{
    tot++;
    edge[tot].to=y;
    edge[tot].dis=z;
    edge[tot].next=head[x];
    head[x]=tot;
}
int add1(int x,int y,int z)
{
    s++;
    edde[s].x=x;
    edde[s].y=y;
    edde[s].z=z;
}
void begin()
{
    s=,tim=,sum=,tot=;
    memset(dfn,,sizeof(dfn));
    memset(low,,sizeof(low));
    memset(vis,,sizeof(vis));
    memset(head,,sizeof(head));
    memset(belong,,sizeof(belong));
}
void tarjan(int now)
{
    dfn[now]=low[now]=++tim;
    stack[++top]=now; vis[now]=true;
    for(int i=head[now];i;i=edge[i].next)
    {
        int t=edge[i].to;
        if(vis[t]) low[now]=min(low[now],dfn[t]);
        else if(!dfn[t]) tarjan(t),low[now]=min(low[now],low[t]);
    }
    if(low[now]==dfn[now])
    {
        sum++;belong[now]=sum;
        for(;stack[top]!=now;top--)
        {
            int x=stack[top];
            belong[x]=sum;vis[x]=false;
        }
        vis[now]=false;top--;
    }
}
void shrink_point()
{
    ;i<=n;i++)
    {
        for(int j=head[i];j;j=edge[j].next)
         if(belong[i]!=belong[edge[j].to])
         {
             int t=edge[j].to;
             add1(belong[i],belong[t],edge[j].dis);
            add1(belong[t],belong[i],edge[j].dis);
          }
    }
}
int cmp(Edde a,Edde b)
{
    return a.z<b.z;
}
int find(int x)
{
    if(x==fa[x]) return x;
    fa[x]=find(fa[x]);
    return fa[x];
}
void kruskal()
{
    ans=,num=;
    ;i<=n;i++) fa[i]=i;
    sort(edde+,edde++s,cmp);
    ;i<=s;i++)
    {
        x=edde[i].x,y=edde[i].y;
        int fx=find(x),fy=find(y);
        if(fx==fy) continue;
        fa[fx]=fy;num++;
        ans+=edde[i].z;
        ) break;
    }
    printf("%lld\n",ans);
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        begin();
        ;i<=m;i++)
          x=read(),y=read(),z=read(),add(x+,y+,z);
        ;i<=n;i++)
         if(!dfn[i]) tarjan(i);
        shrink_point();
        kruskal();
    }
    ;
}

tarjan+最小生成树

wa、、、、

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 300010
#define maxn 0x7fffffff
using namespace std;
bool vis[N];
long long ans;
int n,m,x,y,z,s,tot,num,sum,top,tim;
int fa[N],low[N],dfn[N],cost[N],stack[N],head[N],belong[N];
int read()
{
    ,f=; char ch=getchar();
    ; ch=getchar();}
    +ch-'; ch=getchar();}
    return x*f;
}
struct Edge
{
    int to,dis,next;
}edge[N];
struct Edde
{
    int to,dis,next;
}edde[N];
int add(int x,int y,int z)
{
    tot++;
    edge[tot].to=y;
    edge[tot].dis=z;
    edge[tot].next=head[x];
    head[x]=tot;
}
void begin()
{
    s=,tim=,sum=,tot=;
    memset(dfn,,sizeof(dfn));
    memset(low,,sizeof(low));
    memset(vis,,sizeof(vis));
    memset(head,,sizeof(head));
    memset(belong,,sizeof(belong));
}
void tarjan(int now)
{
    dfn[now]=low[now]=++tim;
    stack[++top]=now; vis[now]=true;
    for(int i=head[now];i;i=edge[i].next)
    {
        int t=edge[i].to;
        if(vis[t]) low[now]=min(low[now],dfn[t]);
        else if(!dfn[t]) tarjan(t),low[now]=min(low[now],low[t]);
    }
    if(low[now]==dfn[now])
    {
        sum++;belong[now]=sum;
        for(;stack[top]!=now;top--)
        {
            int x=stack[top];
            belong[x]=sum;vis[x]=false;
        }
        vis[now]=false;top--;
    }
}
void work()
{
    ans=;
    ;i<=n;i++)
      for(int j=head[i];j;j=edge[j].next)
      {
          int t=edge[j].to;
          if(belong[i]!=belong[t])
            cost[belong[t]]=min(cost[belong[t]],edge[j].dis);
     }
   ;i<=sum;i++)
    if(cost[i]!=maxn) ans+=(long long)cost[i];
   printf("%lld\n",ans);
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        begin();
        ;i<=n;i++) cost[i]=maxn;
        ;i<=m;i++)
          x=read(),y=read(),z=read(),add(x+,y+,z);
        ;i<=n;i++)
         if(!dfn[i]) tarjan(i);
        work();
    }
    ;
}

最新文章

  1. 实现代理设置proxy
  2. js 去除字符串中间的空格
  3. Windows phone应用开发[21]-图片性能优化
  4. js DOM Document类型
  5. Netty4 中的内存管理
  6. android Tab =viewpager+fragmnet
  7. 决定undo表空间的大小
  8. 知识点摸清 - - position属性值之relative与absolute
  9. 网络流(最大密集度子图,分数规划):UvaLive 3709 Hard Life
  10. 设计模式总结1--observer pattern
  11. socket的accept函数解析
  12. kafka使用实例
  13. 使用邮件激活授权/ LightningChart license
  14. RabbitMQ Routing 消息路由
  15. UESTC - 1999 也许这是唯一能阻止乐爷AK的方法( Just for Fun )(回文树)
  16. dcm4che,WADO相关
  17. [LeetCode] 42. Trapping Rain Water_hard tag: Two Pointers
  18. 初始 DQN 程序 所遇到的问题
  19. android 程序更新(没有sdcard)
  20. python函数作用域

热门文章

  1. (七)Mybatis总结之注解开发
  2. File文件存储
  3. 移动端展示pdf(在线打开pdf)
  4. iOS Programming UINavigationController
  5. 设计模式之一:strategy pattern
  6. java实现的判断括号是否成对的代码,()[]{}都可以
  7. (转)淘淘商城系列——VMware添加已配置好的虚拟机
  8. dd - 转换和拷贝文件
  9. 修改qq热键后 安全设置-》自动锁定设置 就能保存住qq的热键了
  10. WebStorm改变字体大小以及更换背景颜色