The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, NNN (≤104\le 10^4≤10

​4

​​), the total number of users, KKK (≤5\le 5≤5), the total number of problems, and MMM (≤105\le 10^5≤10

​5

​​), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to NNN, and the problem id’s are from 1 to KKK. The next line contains KKK positive integers p[i] (i=1, …, KKK), where p[i] corresponds to the full mark of the i-th problem. Then MMM lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1-1−1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20

20 25 25 30

00002 2 12

00007 4 17

00005 1 19

00007 2 25

00005 1 20

00002 2 2

00005 1 15

00001 1 18

00004 3 25

00002 2 25

00005 3 22

00006 4 -1

00001 2 18

00002 1 20

00004 1 15

00002 4 18

00001 3 4

00001 4 2

00005 2 -1

00004 2 0

Sample Output:

1 00002 63 20 25 - 18

2 00005 42 20 0 22 -

2 00007 42 - 25 - 17

2 00001 42 18 18 4 2

5 00004 40 15 0 25 -

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
using namespace std;
#define INF 0x3f3f3f
#define pi acos(-1.0)
#define MAX 100010
#define mod 9973
#define ll long long /* n, k, m;
人 题目 提交 */ const int N =1e5+10;
struct asd{
int name;
int sum;
int a[10];
bool vis[10];
int ff;
};
asd q[N];
bool used[N]; int sco[10];int n,m,k;
bool cmp(asd z,asd x)
{
if(z.sum>x.sum)
return 1;
else if(z.sum==x.sum)
{
int s1,s2;
s1=s2=0;
for(int i=1;i<=k;i++)
{
if(z.a[i]==sco[i])
s1++;
if(x.a[i]==sco[i])
s2++;
}
if(s1>s2)
return 1;
else if(s1==s2)
{
if(z.name<x.name)
return 1;
}
}
return 0;
} int main()
{ memset(used,0,sizeof(used));
cin>>n>>k>>m;
for(int i=1;i<=k;i++) //分数
scanf("%d",&sco[i]); for(int i=1;i<=n;i++) //初始化
{
q[i].name=i; //名字
for(int j=1;j<=5;j++)
q[i].a[j]=0; //分数都是0
for(int j=1;j<=5;j++)
q[i].vis[j]=0; //提交
q[i].sum=q[i].ff=0; //sum分数,ff标记提交的那个
} int mingzi,timu,fenshu;
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&mingzi,&timu,&fenshu);
used[mingzi]=1; //有这个人 if(fenshu!=-1) //交了
{
q[mingzi].ff=1; //就会输出的
q[mingzi].vis[timu]=1; //这道题目会输出;
} if(fenshu>q[mingzi].a[timu]) //更新分数
{
q[mingzi].a[timu]=fenshu;
}
} for(int i=1;i<=n;i++)
{
int x=q[i].name;
if(used[x])
{
for(int j=1;j<=k;j++)
{
q[x].sum+=q[x].a[j];
}
}
} sort(q+1,q+1+n,cmp); /* for(int i=1;i<=n;i++)
{
int x=q[i].name;
if(used[x])
{
printf("%d %d\n",q[i].name,q[i].sum);
}
}*/ int tep,hh,xx;
hh=xx=1;
for(int i=1;i<=n;i++)
{
int x=q[i].name;
if(used[x]&&q[i].ff)
{
printf("1");
printf(" %05d %d",x,q[i].sum);
for(int j=1;j<=k;j++)
{
if(q[i].vis[j])
printf(" %d",q[i].a[j]);
else
printf(" -");
}
puts("");
xx++;
tep=q[x].sum;
used[x]=0;
break;
}
} for(int i=1;i<=n;i++)
{
int x=q[i].name;
if(!used[x]||!q[i].ff)
continue;
if(tep>q[i].sum)
{
hh=xx;
tep=q[i].sum; printf("%d %05d %d",hh,x,tep); for(int j=1;j<=k;j++)
{
if(q[i].vis[j])
printf(" %d",q[i].a[j]);
else
printf(" -");
}
puts("");
}
else if(tep==q[i].sum)
{
printf("%d %05d %d",hh,x,tep);
for(int j=1;j<=k;j++)
{
if(q[i].vis[j])
printf(" %d",q[i].a[j]);
else
printf(" -");
}
puts("");
xx++;
}
}
return 0;
} /*
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
*/

最新文章

  1. java泛型上下限
  2. Android 贝塞尔曲线库
  3. Windows Server 2008 R2 实现多用户同时登陆
  4. Unity协程(Coroutine)管理类——TaskManager工具分享
  5. PHP 性能分析与实验——性能的宏观分析
  6. Oracle基础 数据库备份和恢复
  7. Qt中QFtp获取带有中文的文件名称出现乱码的解决方法(执行操作前就转换编码)
  8. asp:cookies的属性
  9. 有关Windows10中诊断和反馈隐私设置
  10. 计算1~100之间,能被3整除但是不能被7整除的数的和(C语言)
  11. uni-app 点击切换图标
  12. SpringBoot获取配置文件的自定义参数
  13. MySQL transaction
  14. 004-js-md5
  15. Django 之老师讲的教师,班级学生,class_2_teacher四个表格的项目
  16. jquery Nestable 获取改变排序后的json数据 拖动排序
  17. boost--signal
  18. MapReduce-皮尔逊(Pearson)线性相关
  19. 5.7 Components — Sending Actions From Components to Your Application
  20. HTTP Client Performance Improvements

热门文章

  1. 从实例看hibernate的主键生成策略
  2. Effective C++ 条款四 确定对象被使用前已被初始化
  3. 【转载】Http协议与TCP协议简单理解后续
  4. centos下部署项目问题
  5. mysql中修改表字段名/字段长度/字段类型详解
  6. appium安装报错但运行成功
  7. Region Range
  8. GSON的简单示例
  9. java反射机制与动态加载类
  10. 用 nodejs 写一个命令行工具 :创建 react 组件的命令行工具