Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the
bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1)
card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will
contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)
#include <iostream>
#include<cmath>
using namespace std;
int main()
{
double t[10000];
t[0]=0;
int i=0;
for(;t[i]<=5.2;)
{
i++;
t[i]=t[i-1]+1.00/(i+1);
}
double x;
while(cin>>x&&x)
{
int l, r;
l = 0;
r = i ;
while (l + 1 < r)
{
int mid = (l + r) / 2;
if ((t[mid] - x)<-0.0000001)
l = mid;
else
r = mid;
}
cout << r << " card(s)" << endl; } return 0;
}

最新文章

  1. MySQL wamp密码修改
  2. iScroll知识点
  3. 二、Sink例程
  4. JavaWeb学习笔记——Tomcat数据源
  5. Oracle升级前备份和失败回退
  6. vsftp.conf
  7. leetcode2:Add Two Numbers
  8. iOS:实现表格填充和选择操作
  9. iOS 之 时间格式与字符串转换
  10. Vim/Vi常用操作(第二版)
  11. XSS攻击(出现的原因、预防措施......)
  12. Dubbo Mesh 在闲鱼生产环境中的落地实践
  13. 开发日记:JsonCSharpHelp
  14. Go开发之路 -- 指针类型
  15. 算法实践——舞蹈链(Dancing Links)算法求解数独
  16. ImportError: cannot import name cbook
  17. Linux系统构成和基本操作
  18. 2018/7/18Bad English
  19. k8s踩坑记第2篇--3个IP折磨人的故事
  20. pythonl练习笔记——multiprocessing 多进程拷贝文件

热门文章

  1. Laravel 项目使用 Carbon 人性化显示文章发表时间
  2. 解决viewpager+多个fragment+listview,listview展示内容高度不自适应出现多余空白问题
  3. 在16aspx.com上下了一个.net程序,怎么修改它的默认登录名和密码?
  4. linux下使用gcc/g++编译代码时gets函数有错误
  5. 【CodeForces 830C】奇怪的降复杂度
  6. SQL Server判断某个字段是否包含中文/英文字符/数字
  7. Java 并发工具包 java.util.concurrent 用户指南(转)
  8. UITableView的HeaderView和FooterView
  9. mipmap一
  10. IntelliJ IDEA 取消控制台行数限制