Game of Connections
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8772   Accepted: 4324

Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. 
And, no two segments are allowed to intersect. 
It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1. 
You may assume that 1 <= n <= 100.

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input

2
3
-1

Sample Output

2
5

Source

PS:卡特兰数在ACM中比较具体的使用例子有,1括号匹配的种数。2在栈中的自然数出栈的种数。3求多边形内三角形的个数。4,n个数围城圆圈,找不相交线段的个数。5给定n个数,求组成二叉树的种数,本题为第四种。
  h(n)=(4*n-2)/(n+1)*h(n-1).
代码:
 import java.math.*;
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner cin=new Scanner(System.in);
int t;
BigInteger f[]=new BigInteger[1005];
f[1]=BigInteger.valueOf(1);
f[2]=BigInteger.valueOf(2);
f[3]=BigInteger.valueOf(5);
for(int i=4;i<=100;i++){
BigInteger a=BigInteger.valueOf(4*i-2);
BigInteger b=BigInteger.valueOf(i+1);
f[i]=a.multiply(f[i-1]).divide(b);
}
while(cin.hasNextInt())
{
t=cin.nextInt();
if(t==-1) break;
System.out.println(f[t]);
}
}
}
 

最新文章

  1. 腾讯优测-优社区干货精选 | &#160;那些年,我们在Android机型适配上遇到的坑之Camera拍照时快门咔嚓声
  2. oracle中统计重复几次的数据有几条
  3. JavaScript HTML DOM 元素(节点)
  4. Drupal7模块multiselect使用
  5. java中的静态代码块等执行顺序
  6. Docker网络代理设置
  7. H5与Android之间的交互
  8. 自制IPsec_vpn综合实验
  9. EntityFramework Core 2.0执行原始查询如何防止SQL注入?
  10. Nginx 原理解析和配置摘要
  11. 使用git提交代码到github,每次都要输入用户名和密码的解决方法
  12. python模块之自定义模块
  13. [pytorch修改]npyio.py 实现在标签中使用两种delimiter分割文件的行
  14. Win10系列:C#应用控件基础15
  15. javascript判断是用什么设备打开
  16. android:四种基本布局
  17. 查找-&gt;动态查找表-&gt;键树(无代码)
  18. window server 2012 II8 假陌生 碰到的问题
  19. div的定位
  20. C++之条形码,windows下zint库的编译及应用(一)

热门文章

  1. UITableView分隔线
  2. Java中的各种锁
  3. POS开发问题 - 多个弹出框的实现
  4. php支付走过的坑(微信篇 包含h5支付和app支付 注册 秘钥 环境等等配置)
  5. VirtualBox中linux虚拟机和主机间的共享文件设置
  6. SharePoint中低权限用户通过提升权限创建用户组
  7. 笨办法学Python(三十六)
  8. 2.NBU管理NetBackup
  9. React的安装
  10. 【转】android四大组件--ContentProvider详解