题目:

Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 
Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 
Output
For each test case, you should print the sum module 1000000007 in a line.
 
Sample Input
3 4 0
 
Sample Output
0 2

欧拉函数模板:
先求出φn;
由gcd(n,i)=1得gcd(n,n-i)=1,则与n互素的数之和=φ(n)*n/2;
则ans=小于n的数之和-φ(n)*n/2(注意这里不能为“-φ(n)/2*n”或“-n/2*φ(n)”,先/2可能变成0)。
以下为代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
long long n,res,ans;
int main()
{
while(1)
{
scanf("%lld",&n);
if(!n)return 0;
res=n;
int nn=n;
for(int i=2;i*i<=nn;i++)
{
if(nn%i==0)
{
res-=res/i;//减去其中素因子i的倍数的个数 
// res=res/i*(i-1);
while(nn%i==0)nn/=i;//提走素因子i 
}
}
if(nn>1)res-=res/nn;//不能是res--!
// if(nn>1)res=res/n*(n-1);
ans=(n*(n-1)/2-n*res/2)%1000000007;
printf("%lld\n",ans);
}
return 0;
}

  

最新文章

  1. Windows动态库学习心得
  2. 我的android学习经历37
  3. The Bottom of a Graph(tarjan + 缩点)
  4. class不想被复制的两个做法
  5. Objective-C MRC多个对象相互引用的内存管理
  6. Java RandomAccessFile的使用(转载的文章,出处http://www.2cto.com/kf/201208/149816.html)
  7. JS小知识点----基本包装类型和引用类型
  8. WisDom.Net 框架设计(七) 验证框架
  9. 用Enterprise Architect从源码自动生成类图
  10. Django视图,与数据库交互并返回数据
  11. createClass方法
  12. sql语句联表更新(从一个数据库中的一张表更新到另一个数据库的另一张表)
  13. ajax 和jsonp 不是一码事
  14. Flutter 异常处理之图片篇
  15. spring-第一章-基本用法
  16. VMware虚拟机系统无法使用桥接联网
  17. JDBC事务的相关知识
  18. Java面试题 BAT 大公司面试题整理总结!
  19. 前端 -----js 定时器
  20. POJ - 3122 Pie(二分)

热门文章

  1. FTPHelper类
  2. diy文件系统上创建文件的流程
  3. Golang程序性能分析
  4. Mysql代码建外键问题
  5. 【BZOJ2597】[Wc2007]剪刀石头布 最小费用流
  6. java设计模式之迭代器模式
  7. Eclipse如何删除插件
  8. 九度OJ 1178:复数集合 (插入排序)
  9. 2-phase-commit 3-phase-commit
  10. Swift 学习笔记 (闭包)