题目:

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

题解:

  期望dp入门题,详见http://blog.csdn.net/xingyeyongheng/article/details/25179481

  主要是那个倒推的思想在期望dp中用得很多

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cctype>
#include<ctime>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=;
int n,s;
double f[N][N];
int main(){
//freopen("a.in","r",stdin);
while(scanf("%d%d",&n,&s)!=EOF){
memset(f,,sizeof(f));
for(int i=n;i>=;i--)
for(int j=s;j>=;j--){
if(i==n&&j==s) continue;
double p1=(n-i)*(s-j)*1.0/(n*s)*1.0;
double p2=i*(s-j)*1.0/(n*s)*1.0;
double p3=(n-i)*j*1.0/(n*s)*1.0;
double p4=i*j*1.0/(n*s)*1.0;
f[i][j]=(f[i+][j+]*p1+f[i][j+]*p2+f[i+][j]*p3+)/(-p4);
}
printf("%0.4f",f[][]);
}
return ;
}

最新文章

  1. ios app 打包上传 app store(Application Loader)
  2. HDU 5067
  3. wikioi 1973 Fibonacci数列【输出第N项的值】
  4. SDK 与MFC
  5. 导入jsp
  6. 【剑指offer】堆栈推弹出序列
  7. 【python标准库】内建函数
  8. mysql 和excel相互转换
  9. 《连载 | 物联网框架ServerSuperIO教程》- 16.OPC Server的使用步骤。附:3.3 发布与版本更新说明。
  10. 搭建 Keepalived + Nginx + Tomcat 的高可用负载均衡架构
  11. 一个简单的div弹出层的小例子
  12. RTMPdump 使用说明
  13. 【MVC】ASP.NET MVC之数据验证
  14. C#对象与XMl文件之间的相互转换(转)
  15. 帝国cms修改栏目后文章列表的url错误怎么解决
  16. (转载)winform图片标尺控件
  17. Django权限auth模块详解
  18. 【Canal源码分析】TableMetaTSDB
  19. maven中distributionManagement
  20. js如何获取前后连续n天的时间

热门文章

  1. 10个HTML5 实战教程 提升你的综合开发能力
  2. R+hadoop
  3. ASP.NET补充
  4. I am too vegetable to all kill the 51nod problems on level 2 and 3.
  5. GPIO实现I2C协议模拟(1)
  6. 【转】Mysql查询语句优化策略
  7. .net core 在IIS上发布502问题
  8. matplotlib(二)&mdash;&mdash;matplotlib控制坐标轴第一个刻度到原点距离
  9. tcl之string操作-match/map/大小写转换
  10. HDU 6156 回文 数位DP(2017CCPC)