Priest John's Busiest Day
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10010   Accepted: 3425   Special Judge

Description

John is the only priest in his town. September 1st is the John's busiest day in a year because there is an old legend in the town that the couple who get married on that day will be forever blessed by the God of Love. This year N couples plan to get married on the blessed day. The i-th couple plan to hold their wedding from time Si to time Ti. According to the traditions in the town, there must be a special ceremony on which the couple stand before the priest and accept blessings. The i-th couple need Di minutes to finish this ceremony. Moreover, this ceremony must be either at the beginning or the ending of the wedding (i.e. it must be either from Si to Si + Di, or from Ti - Di to Ti). Could you tell John how to arrange his schedule so that he can present at every special ceremonies of the weddings.

Note that John can not be present at two weddings simultaneously.

Input

The first line contains a integer N ( 1 ≤ N ≤ 1000). 
The next N lines contain the SiTi and DiSi and Ti are in the format of hh:mm.

Output

The first line of output contains "YES" or "NO" indicating whether John can be present at every special ceremony. If it is "YES", output another N lines describing the staring time and finishing time of all the ceremonies.

Sample Input

2
08:00 09:00 30
08:15 09:00 20

Sample Output

YES
08:00 08:30
08:40 09:00

题目链接:POJ 3683

挑战程序书上的例题,重新学习了一下2-SAT,一般的2-SAT是给出一些矛盾的条件,然后根据这些矛盾的条件用强连通分量算法来做。

首先要知道把什么东西拆点,一般是去拆具有两个对立面的事物,比如这题就是神父出现在开头和神父出现在结尾,两者就是不能同时发生的对立面,然后记这两个对立面为$x_i$与$\lnot x_i$,显然一般情况下如果a与b矛盾那么就是说“a与b不能同时发生”,转换成标记符号就是$\lnot (a \land b)$,然后把这个式子拆开得到$\lnot a\lor\lnot b$,那么得到这样一个析取范式,我们可以将他转换成蕴含式子,即$(a \to \lnot b)\land(b \to \lnot a)$,这显然可以转换成两条有向边$<a, \lnot b>$与$<b, \lnot a>$,然后对图进行DFS得到强连通分量,然后看$\lnot x_i$与$x_i$是否在同一个强连通分量里,如果在同一个scc中显然是矛盾的,这题的话就第i个时间段和第j个时间段的开头和结束位置共4种关心进行判断,冲突就按上面的方法连边再scc处理即可,如果存在方案,只要判断$x_i$所在的连通分量编号与$\lnot x_i$所在的连通分量编号即可

代码:

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <sstream>
#include <numeric>
#include <cstring>
#include <bitset>
#include <string>
#include <deque>
#include <stack>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
typedef pair<int, int> pii;
typedef long long LL;
const double PI = acos(-1.0);
const int N = 1010;
const int MAXV = N * 2;
const int MAXE = N * N * 4 * 2;
struct edge
{
int to, nxt;
edge() {}
edge(int _to, int _nxt): to(_to), nxt(_nxt) {}
};
edge E[MAXE];
int head[MAXV], tot;
int dfn[MAXV], low[MAXV], belong[MAXV], st[MAXV], top, ts, ins[MAXV], sc;
int s[N], t[N], d[N]; void init()
{
CLR(head, -1);
tot = 0;
CLR(dfn, 0);
CLR(low, 0);
top = sc = 0;
CLR(ins, 0);
sc = 0;
}
inline void add(int s, int t)
{
E[tot] = edge(t, head[s]);
head[s] = tot++;
}
void Tarjan(int u)
{
low[u] = dfn[u] = ++ts;
st[top++] = u;
ins[u] = 1;
for (int i = head[u]; ~i; i = E[i].nxt)
{
int v = E[i].to;
if (!dfn[v])
{
Tarjan(v);
low[u] = min(low[u], low[v]);
}
else if (ins[v])
low[u] = min(low[u], dfn[v]);
}
if (low[u] == dfn[u])
{
++sc;
int v;
do
{
v = st[--top];
ins[v] = 0;
belong[v] = sc;
} while (u != v);
}
}
int main(void)
{
int n, i, j;
while (~scanf("%d", &n))
{
init();
for (i = 1; i <= n; ++i)
{
int h1, m1, h2, m2;
scanf(" %d:%d %d:%d %d", &h1, &m1, &h2, &m2, &d[i]);
s[i] = h1 * 60 + m1;
t[i] = h2 * 60 + m2;
}
for (i = 1; i <= n; ++i) //n*n*4*2
{
for (j = 1; j <= n; ++j)
{
if (i == j)
continue;
if (min(s[i] + d[i], s[j] + d[j]) > max(s[i], s[j])) //s-s
{
add(i, j + n);
add(j, i + n);
}
if (min(s[i] + d[i], t[j]) > max(s[i], t[j] - d[j])) //s-t
{
add(i, j);
add(j + n, i + n);
}
if (min(t[i], s[j] + d[j]) > max(t[i] - d[i], s[j])) //t-s
{
add(i + n, j + n);
add(j, i);
}
if (min(t[i], t[j]) > max(t[i] - d[i], t[j] - d[j])) //t-t
{
add(i + n, j);
add(j + n, i);
}
}
}
for (i = 1; i <= (n << 1); ++i)
if (!dfn[i])
Tarjan(i);
int flag = 1;
for (i = 1; i <= n; ++i)
if (belong[i] == belong[i + n])
flag = 0;
if (!flag)
puts("NO");
else
{
puts("YES");
for (i = 1; i <= n; ++i)
{
if (belong[i] < belong[i + n])
printf("%02d:%02d %02d:%02d\n", s[i] / 60, s[i] % 60, (s[i] + d[i]) / 60, (s[i] + d[i]) % 60);
else
printf("%02d:%02d %02d:%02d\n", (t[i] - d[i]) / 60, (t[i] - d[i]) % 60, (t[i]) / 60, (t[i]) % 60);
}
}
}
return 0;
}

最新文章

  1. sizzle分析记录:词法分析器(tokenize)
  2. Convert HTML Entities
  3. iOS 面试题及答案
  4. supervisor很赞!
  5. Using the viewport meta tag to control layout on mobile browsers
  6. 在终端中创建一个简单的mysql表格
  7. rspec学习01
  8. PHP 9 大缓存技术总结
  9. IOS UI 第六篇:基本UI
  10. 如何在Excel中少犯二(I)
  11. PE文件格式详解,第一讲,DOS头文件格式
  12. SEO是件贼有意思的事情 golang入坑系列
  13. printf(&quot;Hello 2018!&quot;);
  14. 烽火2640路由器命令行手册-12-IBM网络配置命令
  15. cesium 之自定义气泡窗口 infoWindow 后续优化篇(附源码下载)
  16. .net core 2.x - 日志 - to elasticsearch - (2)
  17. thinkphp5控制器
  18. MySQL Point in Time Recovery the Right Way
  19. docker容器备份、恢复和迁移volume方案
  20. java单双派机制理解

热门文章

  1. 手机上如何远程控制Linux服务器?
  2. python_63_装饰器6
  3. 借鉴一些关于js框架的东西
  4. ubuntu jdk install
  5. ipynb--&gt;pdf
  6. C#关系运算符
  7. Too Rich HDU - 5527 (贪心+dfs)
  8. JavaScript设置div中的文字滚动起来 实现滚动效果
  9. Nginx认证
  10. 【JAVA】apachehttpclient设置http1.0短链接