World Cup

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 62   Accepted Submission(s) : 29
Problem Description

A World Cup of association football is being held with teams from around the world. The standing is based on the number of points won by the teams, and the distribution of points is done the usual way. That is, when a teams wins a match, it receives 3 points; if the match ends in a draw, both teams receive 1 point; and the loser doesn’t receive any points.

Given the current standing of the teams and the number of teams participating in the World Cup, your task is to determine how many matches ended in a draw till the moment.

 
Input

The input contains several test cases. The first line of a test case contains two integers T and N, indicating respectively the number of participating teams (0 ≤T ≤ 200) and the number of played matches (0 ≤ N ≤ 10000). Each one of the T lines below contains the name of the team (a string of at most 10 letter and digits), followed by a whitespace, then the number of points that the team obtained till the moment. The end of input is indicated by T = 0.

 
Output

For each one of the test cases, your program should print a single line containing an integer, representing the quantity of matches that ended in a draw till the moment.

 
Sample Input
3 3 Brasil 3 Australia 3 Croacia 3 3 3 Brasil 5 Japao 1 Australia 1 0 0
 
Sample Output
0 2
 
Source
PKU

 #include <stdio.h>
#include <stdlib.h> int main()
{
int T,n,a[],i,sign;
while(scanf("%d%d",&T,&n),T!=)
{
sign=;
while(T--)
{
scanf("%s",a);
scanf("%d",&i);
sign+=i;
}
printf("%d\n",n*-sign);
}
return ;
}

最新文章

  1. 修改git的远程仓库命令
  2. CODE[VS] 1346 HelloWorld编译器
  3. 【Andorid开发框架学习】之Mina开发之服务器开发
  4. flask页面操作gpn接口
  5. cc.RepeatForever和cc.Spawn冲突
  6. mysql位_01检查错误代码的方法
  7. 初识ajax
  8. 解决导入MySQL数据库提示"Unknown character set: 'utf8mb4'"错误
  9. 转:彻底搞清referrer和origin
  10. 一致推崇的Linux系统还有那么安全吗?
  11. collections模块
  12. Webshell密码极速爆破工具 – cheetah
  13. 【转】RHEL(RedHat Enterprise Linux)5/6 ISO镜像下载
  14. vue-生存周期
  15. [C语言]逆序的三位数
  16. vue的双向数据绑定实现原理
  17. leetcode414-第三大的数
  18. php中http_build_query函数
  19. Windows store app[Part 2]:全新的File System与Uri不匹配的问题
  20. 【二分】Codeforces Round #417 (Div. 2) C. Sagheer and Nubian Market

热门文章

  1. jquery学习笔记3 jq遍历
  2. win10下安装Django
  3. hdu1024
  4. 第一百零四节,JavaScript时间与日期
  5. 遮盖层实现(jQuery+css+html)
  6. 向网页中写入js和css
  7. 关于逆波兰式的c++实现
  8. Leetcode018 4Sum
  9. Chapter 16_2 继承
  10. IOS开发—UITableView重用机制的了解